summaryrefslogtreecommitdiff
path: root/app-benchmarks/acovea-gtk/acovea-gtk-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/acovea-gtk/acovea-gtk-1.0.1.ebuild')
-rw-r--r--app-benchmarks/acovea-gtk/acovea-gtk-1.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-benchmarks/acovea-gtk/acovea-gtk-1.0.1.ebuild b/app-benchmarks/acovea-gtk/acovea-gtk-1.0.1.ebuild
new file mode 100644
index 000000000000..b4cb99ed03b9
--- /dev/null
+++ b/app-benchmarks/acovea-gtk/acovea-gtk-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Analysis of Compiler Options via Evolutionary Algorithm GUI"
+HOMEPAGE="http://www.coyotegulch.com/products/acovea/"
+SRC_URI="http://www.coyotegulch.com/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+
+RDEPEND=">=app-benchmarks/acovea-5
+ dev-cpp/gtkmm:2.4"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ use unicode && epatch "${FILESDIR}"/${P}-unicode.patch
+ epatch "${FILESDIR}"/${P}-{libbrahe,libsigc,gcc4.3}.patch
+ append-cxxflags -std=c++11
+ eautoreconf
+}
+
+src_install() {
+ default
+ make_desktop_entry "${PN}" Acovea-gtk \
+ /usr/share/acovea-gtk/pixmaps/acovea_icon_064.png System
+}