summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:12:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 19:12:17 +0100
commit580d27c925587ae7c65ac3d2706b1c8ce42b0463 (patch)
treebe152335ae762fc8404bd696b02425db417ae5c9 /x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild
parent47af801ff0ee4a4207b36e6917b1e496354940c0 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild')
-rw-r--r--x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild b/x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild
new file mode 100644
index 000000000000..bda76dc009c0
--- /dev/null
+++ b/x11-plugins/wmcalendar/wmcalendar-0.5.2-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="a calendar dockapp"
+HOMEPAGE="http://wmcalendar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/libical
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ../{BUGS,CHANGES,HINTS,README,TODO} )
+
+S=${WORKDIR}/${P}/Src
+
+PATCHES=( "${FILESDIR}"/${P}-exit-sin-and-cos.patch
+ "${FILESDIR}"/${P}-rename_kill_func.patch
+ "${FILESDIR}"/${P}-ical.patch )
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+}