summaryrefslogtreecommitdiff
path: root/x11-misc/safeeyes/safeeyes-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-19 17:57:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-19 17:57:29 +0100
commitd473a706836012853193afc7000922601e4ada61 (patch)
tree01c43bd6b2121d90bc97ead47dd7654d9402ea1d /x11-misc/safeeyes/safeeyes-2.0.0.ebuild
parent420eeee727d39d869d864caddb04a80dafda7160 (diff)
gentoo resync : 19.10.2017
Diffstat (limited to 'x11-misc/safeeyes/safeeyes-2.0.0.ebuild')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.0.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.0.0.ebuild b/x11-misc/safeeyes/safeeyes-2.0.0.ebuild
new file mode 100644
index 000000000000..98d9b9cc1123
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit gnome2-utils xdg distutils-r1
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+CDEPEND="${PYTHON_DEPS}"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="${CDEPEND}
+ dev-libs/libappindicator:3
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ portaudio? ( dev-python/pyaudio[${PYTHON_USEDEP}] )
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ x11-apps/xprop
+ x11-misc/xprintidle
+ "
+
+DOCS=(
+ README.md
+)
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}