summaryrefslogtreecommitdiff
path: root/virtual/python-futures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
commit1db00cc6e94b90c08090bb5b8c406622946c4ae5 (patch)
treec34bf820c2809fb7e08ed5564df2a25cf759516f /virtual/python-futures
parent693cc9b6e847a01c1bb692153021aaf9fb0fab25 (diff)
gentoo resync 31.01.2019
Diffstat (limited to 'virtual/python-futures')
-rw-r--r--virtual/python-futures/Manifest1
-rw-r--r--virtual/python-futures/python-futures-1.ebuild16
2 files changed, 17 insertions, 0 deletions
diff --git a/virtual/python-futures/Manifest b/virtual/python-futures/Manifest
index efb866de5638..68b3d7da10e3 100644
--- a/virtual/python-futures/Manifest
+++ b/virtual/python-futures/Manifest
@@ -1,2 +1,3 @@
EBUILD python-futures-0.ebuild 501 BLAKE2B a223467564ad7b91e91f49c42b19b3b8f5dd6c066c096c6694cdbcf095bea048e7d9f1e1a01f6a1836e0dd643ca21e77698f83c9305090f05d26f3db48668049 SHA512 091d9344eb226dad9afd08f51fc9ee5ed93380af33bff9e22769c57075abbb90fff4ed887d7a9f94ab95f41db2bcee9232271af764bb069ce627b74919f3c66a
+EBUILD python-futures-1.ebuild 511 BLAKE2B f70eef636e2f2f7034e9dc273549a4e287511b58e3d1b241e72504ba07db64fa556addec7a5efcd5aa11d996844b4a1d3770ace653e2042f07e7b49d0fd3bfea SHA512 6f3e0eff7c0f30e615e3ebb96944cb21148c2c2cadf49db566425f4608a0a0668a026438dbd68d4d4072b5be424cdbe6ceaef7028b7d39fa78bee889584da51b
MISC metadata.xml 240 BLAKE2B 41e6a4d9da33dab2decc5ff419924f382a8f64d27a81fdb97576db8c6cf125be95911747946ec8be1b453f56617fef1084f5947f84b50a8db419d46df2ae8a0f SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59
diff --git a/virtual/python-futures/python-futures-1.ebuild b/virtual/python-futures/python-futures-1.ebuild
new file mode 100644
index 000000000000..2806c87b5f3e
--- /dev/null
+++ b/virtual/python-futures/python-futures-1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit python-r1
+
+DESCRIPTION="A virtual for the Python concurrent.futures module"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh sparc ~x86 ~amd64-fbsd ~amd64-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' python2_7 pypy)"