summaryrefslogtreecommitdiff
path: root/sys-libs/kpmcore/kpmcore-21.08.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
commitfbda87924e6faa7a1919f1a2b4182490bde5ec5c (patch)
treef3114a4ed212a754756adce027aeef3a4a1a2e2a /sys-libs/kpmcore/kpmcore-21.08.1.ebuild
parent3b08f674e3f771b49370edb144dab0958c8cf721 (diff)
gentoo resync : 03.09.2021
Diffstat (limited to 'sys-libs/kpmcore/kpmcore-21.08.1.ebuild')
-rw-r--r--sys-libs/kpmcore/kpmcore-21.08.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-libs/kpmcore/kpmcore-21.08.1.ebuild b/sys-libs/kpmcore/kpmcore-21.08.1.ebuild
new file mode 100644
index 000000000000..ba39ac6ae27c
--- /dev/null
+++ b/sys-libs/kpmcore/kpmcore-21.08.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_NONGUI="true"
+KDE_GEAR="true"
+KFMIN=5.84.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Library for managing partitions"
+HOMEPAGE="https://apps.kde.org/partitionmanager/"
+
+LICENSE="GPL-3"
+SLOT="5/10"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# bug 689468, tests need polkit etc.
+RESTRICT="test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=sys-apps/util-linux-2.33.2
+ sys-auth/polkit-qt
+"
+RDEPEND="${DEPEND}"