summaryrefslogtreecommitdiff
path: root/sys-cluster/sanlock/sanlock-3.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sys-cluster/sanlock/sanlock-3.8.2.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sys-cluster/sanlock/sanlock-3.8.2.ebuild')
-rw-r--r--sys-cluster/sanlock/sanlock-3.8.2.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/sys-cluster/sanlock/sanlock-3.8.2.ebuild b/sys-cluster/sanlock/sanlock-3.8.2.ebuild
index 8426d4f6d3ca..baada07ab2ae 100644
--- a/sys-cluster/sanlock/sanlock-3.8.2.ebuild
+++ b/sys-cluster/sanlock/sanlock-3.8.2.ebuild
@@ -35,7 +35,7 @@ pkg_setup() {
if linux_config_exists; then
if ! linux_chkconfig_present SOFT_WATCHDOG; then
ewarn ""
- ewarn "$warning"
+ ewarn "${warning}"
ewarn ""
fi
else
@@ -47,19 +47,29 @@ pkg_setup() {
src_compile() {
for d in wdmd src fence_sanlock reset; do
- cd $d; emake; cd ..
+ cd ${d} || die
+ emake
+ cd .. || die
done
+
if use python; then
- cd python; python_foreach_impl emake; cd ..
+ cd python || die
+ python_foreach_impl emake
+ cd .. || die
fi
}
src_install() {
for d in wdmd src fence_sanlock reset; do
- cd $d; emake DESTDIR="${D}" LIBDIR="${EROOT}usr/$(get_libdir)" install; cd ..
+ cd ${d} || die
+ emake DESTDIR="${D}" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ cd .. || die
done
+
if use python; then
- cd python; python_foreach_impl emake DESTDIR="${D}" install; cd ..
+ cd python || die
+ python_foreach_impl emake DESTDIR="${D}" install
+ cd .. || die
fi
# config
@@ -78,7 +88,7 @@ src_install() {
# systemd
systemd_newunit init.d/sanlock.service.native sanlock.service
- sed -i 's,^ExecStartPre=,#ExecStartPre=,' init.d/wdmd.service.native
+ sed -i 's,^ExecStartPre=,#ExecStartPre=,' init.d/wdmd.service.native || die
systemd_newunit init.d/wdmd.service.native wdmd.service
systemd_dounit init.d/sanlk-resetd.service
#systemd_dounit ${FILESDIR}/fence_sanlockd.service