summaryrefslogtreecommitdiff
path: root/sys-block/open-isns/open-isns-0.98.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-03 16:17:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-03 16:17:22 +0000
commit4cd2370bed609c118b6edfde5d3f116e5c35b897 (patch)
treeec58f2c41f49754e41521d5ebc9dce4597ddd0a5 /sys-block/open-isns/open-isns-0.98.ebuild
parentf443475c824b4b5c086e6d040961cb35ad81bc60 (diff)
gentoo resync : 03.12.2017
Diffstat (limited to 'sys-block/open-isns/open-isns-0.98.ebuild')
-rw-r--r--sys-block/open-isns/open-isns-0.98.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-block/open-isns/open-isns-0.98.ebuild b/sys-block/open-isns/open-isns-0.98.ebuild
new file mode 100644
index 000000000000..a392ec70ea15
--- /dev/null
+++ b/sys-block/open-isns/open-isns-0.98.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="iSNS server and client for Linux"
+HOMEPAGE="https://github.com/open-iscsi/open-isns"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug slp ssl static"
+
+DEPEND="
+ ssl? ( dev-libs/openssl:= )
+ slp? ( net-libs/openslp )"
+RDEPEND="${DEPEND}"
+
+PATCHES=()
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI
+ append-lfs-flags
+ econf $(use_with slp) \
+ $(use_with ssl security) \
+ $(use_enable !static shared)
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install_hdrs
+ emake DESTDIR="${D}" install_lib
+}