summaryrefslogtreecommitdiff
path: root/sys-apps/usermode-utilities/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/usermode-utilities/files
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/usermode-utilities/files')
-rw-r--r--sys-apps/usermode-utilities/files/usermode-utilities-20070815-headers.patch27
-rw-r--r--sys-apps/usermode-utilities/files/usermode-utilities-20070815-humfsify-owner.patch12
-rw-r--r--sys-apps/usermode-utilities/files/usermode-utilities-20070815-rollup.patch101
3 files changed, 140 insertions, 0 deletions
diff --git a/sys-apps/usermode-utilities/files/usermode-utilities-20070815-headers.patch b/sys-apps/usermode-utilities/files/usermode-utilities-20070815-headers.patch
new file mode 100644
index 000000000000..13fd556ec98d
--- /dev/null
+++ b/sys-apps/usermode-utilities/files/usermode-utilities-20070815-headers.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/580816
+
+include headers needed by targets
+
+--- b/tools-20070815/uml_net/ethertap.c
++++ a/tools-20070815/uml_net/ethertap.c
+@@ -13,6 +13,7 @@
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>
+ #include <net/if.h>
++#include <sys/select.h>
+ #include "host.h"
+ #include "output.h"
+
+
+for major/minor macros
+
+--- b/tools-20070815/uml_net/host.c
++++ a/tools-20070815/uml_net/host.c
+@@ -10,6 +10,7 @@
+ #include <ctype.h>
+ #include <sys/wait.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include "output.h"
+ #include "host.h"
+
diff --git a/sys-apps/usermode-utilities/files/usermode-utilities-20070815-humfsify-owner.patch b/sys-apps/usermode-utilities/files/usermode-utilities-20070815-humfsify-owner.patch
new file mode 100644
index 000000000000..9d02498052f0
--- /dev/null
+++ b/sys-apps/usermode-utilities/files/usermode-utilities-20070815-humfsify-owner.patch
@@ -0,0 +1,12 @@
+diff '--exclude-from=/home/dang/.scripts/diffrc' -up -ruN tools-20070815.orig/humfsify/Makefile tools-20070815/humfsify/Makefile
+--- tools-20070815.orig/humfsify/Makefile 2006-05-25 14:37:01.000000000 -0400
++++ tools-20070815/humfsify/Makefile 2011-05-02 11:04:32.531034342 -0400
+@@ -4,7 +4,7 @@ all:
+
+ install:
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -o 0755 $(BIN) $(DESTDIR)$(BIN_DIR)
++ install -m 0755 $(BIN) $(DESTDIR)$(BIN_DIR)
+
+ clean:
+ rm -f *~
diff --git a/sys-apps/usermode-utilities/files/usermode-utilities-20070815-rollup.patch b/sys-apps/usermode-utilities/files/usermode-utilities-20070815-rollup.patch
new file mode 100644
index 000000000000..f88e20663f5b
--- /dev/null
+++ b/sys-apps/usermode-utilities/files/usermode-utilities-20070815-rollup.patch
@@ -0,0 +1,101 @@
+diff '--exclude-from=/home/dang/.scripts/diffrc' -up -ruN tools-20070815.orig/jail/Makefile tools-20070815/jail/Makefile
+--- tools-20070815.orig/jail/Makefile 2006-02-27 14:51:46.000000000 -0500
++++ tools-20070815/jail/Makefile 2010-08-04 22:17:56.869103217 -0400
+@@ -11,7 +11,7 @@ $(BIN) : $(OBJS)
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(SBIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(SBIN_DIR)
++ install $(BIN) $(DESTDIR)$(SBIN_DIR)
+
+ clean :
+ rm -rf *~ $(BIN) $(OBJS) cell[0-9]* core* tty_log_cell*
+diff '--exclude-from=/home/dang/.scripts/diffrc' -up -ruN tools-20070815.orig/jailtest/Makefile tools-20070815/jailtest/Makefile
+--- tools-20070815.orig/jailtest/Makefile 2006-02-27 14:52:53.000000000 -0500
++++ tools-20070815/jailtest/Makefile 2010-08-04 22:17:56.870032258 -0400
+@@ -14,4 +14,4 @@ clean :
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
+diff '--exclude-from=/home/dang/.scripts/diffrc' -up -ruN tools-20070815.orig/mconsole/Makefile tools-20070815/mconsole/Makefile
+--- tools-20070815.orig/mconsole/Makefile 2006-02-27 15:03:01.000000000 -0500
++++ tools-20070815/mconsole/Makefile 2010-08-04 22:17:56.916031770 -0400
+@@ -15,4 +15,4 @@ clean :
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
+diff '--exclude-from=/home/dang/.scripts/diffrc' -up -ruN tools-20070815.orig/moo/Makefile tools-20070815/moo/Makefile
+--- tools-20070815.orig/moo/Makefile 2006-02-27 15:08:49.000000000 -0500
++++ tools-20070815/moo/Makefile 2010-08-04 22:17:56.938282085 -0400
+@@ -23,4 +23,4 @@ clean :
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
+diff '--exclude-from=/home/dang/.scripts/diffrc' -up -ruN tools-20070815.orig/port-helper/Makefile tools-20070815/port-helper/Makefile
+--- tools-20070815.orig/port-helper/Makefile 2006-02-27 15:18:40.000000000 -0500
++++ tools-20070815/port-helper/Makefile 2010-08-04 22:17:56.938282085 -0400
+@@ -15,4 +15,4 @@ clean :
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(LIB_DIR)
+- install -s $(BIN) $(DESTDIR)$(LIB_DIR)
++ install $(BIN) $(DESTDIR)$(LIB_DIR)
+diff '--exclude-from=/home/dang/.scripts/diffrc' -up -ruN tools-20070815.orig/tunctl/Makefile tools-20070815/tunctl/Makefile
+--- tools-20070815.orig/tunctl/Makefile 2006-02-27 15:19:52.000000000 -0500
++++ tools-20070815/tunctl/Makefile 2010-08-04 22:17:56.939282225 -0400
+@@ -14,4 +14,4 @@ clean :
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
+diff '--exclude-from=/home/dang/.scripts/diffrc' -up -ruN tools-20070815.orig/umlfs/Makefile tools-20070815/umlfs/Makefile
+--- tools-20070815.orig/umlfs/Makefile 2006-02-27 16:11:25.000000000 -0500
++++ tools-20070815/umlfs/Makefile 2010-08-04 22:17:56.940282085 -0400
+@@ -16,4 +16,4 @@ clean :
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
+diff '--exclude-from=/home/dang/.scripts/diffrc' -up -ruN tools-20070815.orig/uml_net/Makefile tools-20070815/uml_net/Makefile
+--- tools-20070815.orig/uml_net/Makefile 2006-02-27 15:19:52.000000000 -0500
++++ tools-20070815/uml_net/Makefile 2010-08-04 22:23:40.459151826 -0400
+@@ -2,6 +2,7 @@ TUNTAP = $(shell [ -e /usr/include/linux
+
+ BIN = uml_net
+ CFLAGS ?= -g -Wall
++LDFLAGS += -Wl,-z,now
+ override CFLAGS += $(TUNTAP)
+
+ BIN_DIR ?= /usr/bin
+@@ -22,4 +23,4 @@ clean :
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s -m 04755 $(BIN) $(DESTDIR)$(BIN_DIR)
++ install -m 04755 $(BIN) $(DESTDIR)$(BIN_DIR)
+diff '--exclude-from=/home/dang/.scripts/diffrc' -up -ruN tools-20070815.orig/uml_switch/Makefile tools-20070815/uml_switch/Makefile
+--- tools-20070815.orig/uml_switch/Makefile 2006-02-27 15:20:26.000000000 -0500
++++ tools-20070815/uml_switch/Makefile 2010-08-04 22:17:56.942283133 -0400
+@@ -21,4 +21,4 @@ clean :
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
+diff '--exclude-from=/home/dang/.scripts/diffrc' -up -ruN tools-20070815.orig/watchdog/Makefile tools-20070815/watchdog/Makefile
+--- tools-20070815.orig/watchdog/Makefile 2006-02-27 15:55:34.000000000 -0500
++++ tools-20070815/watchdog/Makefile 2010-08-04 22:17:56.943282225 -0400
+@@ -14,4 +14,4 @@ clean :
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)