summaryrefslogtreecommitdiff
path: root/sys-apps/superdiag/superdiag-1.5.0.20210507.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /sys-apps/superdiag/superdiag-1.5.0.20210507.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'sys-apps/superdiag/superdiag-1.5.0.20210507.ebuild')
-rw-r--r--sys-apps/superdiag/superdiag-1.5.0.20210507.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/superdiag/superdiag-1.5.0.20210507.ebuild b/sys-apps/superdiag/superdiag-1.5.0.20210507.ebuild
new file mode 100644
index 000000000000..cea0aa94f07e
--- /dev/null
+++ b/sys-apps/superdiag/superdiag-1.5.0.20210507.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="SuperDiag"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="Provides the capability to determine the health of Supermicro servers components"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_PN}_${MY_PV}_${MY_DATE}.zip"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+IUSE="iso usb"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=SDO"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_unpack() {
+ unpack ${A}
+
+ if use iso; then
+ unzip Diagnose_Remotely/ISOFor${MY_PN}_${MY_PV}.zip -d iso || die
+ fi
+
+ if use usb; then
+ unzip Diagnose_Remotely/USBFor${MY_PN}_${MY_PV}.zip -d usb || die
+ fi
+}
+
+src_install() {
+ insinto /usr/share/superdiag
+ doins startup.nsh ${MY_PN}.efi EFI/Boot/BootX64.efi
+
+ local DOCS=(
+ "Supermicro Super Diagnostics Offline readme.txt"
+ "Supermicro Super Diagnostics Offline User Guide V${MY_PV}.pdf"
+ )
+ dodoc "${DOCS[@]}"
+
+ if use iso; then
+ insinto /usr/share/superdiag/ISO
+ doins iso/${MY_PN}_${MY_PV}.iso
+
+ newdoc iso/Readme.txt Readme.ISO.txt
+ fi
+
+ if use usb; then
+ insinto /usr/share/superdiag/USB
+ doins usb/startup.nsh
+
+ dosym ../BootX64.efi /usr/share/superdiag/USB/BootX64.efi
+ dosym ../${MY_PN}.efi /usr/share/superdiag/USB/${MY_PN}.efi
+
+ newdoc usb/Readme.txt Readme.USB.txt
+ fi
+}