summaryrefslogtreecommitdiff
path: root/sys-apps/osinfo-db/osinfo-db-20220516.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-apps/osinfo-db/osinfo-db-20220516.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-apps/osinfo-db/osinfo-db-20220516.ebuild')
-rw-r--r--sys-apps/osinfo-db/osinfo-db-20220516.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/osinfo-db/osinfo-db-20220516.ebuild b/sys-apps/osinfo-db/osinfo-db-20220516.ebuild
new file mode 100644
index 000000000000..28ae854564ac
--- /dev/null
+++ b/sys-apps/osinfo-db/osinfo-db-20220516.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="osinfo database files"
+HOMEPAGE="https://libosinfo.org/ https://gitlab.com/libosinfo/osinfo-db"
+SRC_URI="https://releases.pagure.org/libosinfo/${P}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="sys-apps/osinfo-db-tools"
+
+# we don't depend on intltool here, contrary to README, as the tarball already
+# contains the processed results with translations in XML files
+
+src_unpack() { :; }
+
+src_install() {
+ osinfo-db-import --root "${D}" --dir "/usr/share/osinfo" "${DISTDIR}/${A}"
+}