summaryrefslogtreecommitdiff
path: root/sys-apps/microcode-ctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
commit721254b86a09bdedd5eefd0de7899c90ea2ead1a (patch)
tree895fca7b3bd570d8df743dd518a6f36deca1a241 /sys-apps/microcode-ctl
parent618c3037024b4e5328531cdc07c6ceb7486f5329 (diff)
gentoo resync : 01.01.2018
Diffstat (limited to 'sys-apps/microcode-ctl')
-rw-r--r--sys-apps/microcode-ctl/Manifest1
-rw-r--r--sys-apps/microcode-ctl/microcode-ctl-1.28-r2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/microcode-ctl/Manifest b/sys-apps/microcode-ctl/Manifest
index 8eb29df4cd86..d5282921cdca 100644
--- a/sys-apps/microcode-ctl/Manifest
+++ b/sys-apps/microcode-ctl/Manifest
@@ -7,5 +7,6 @@ DIST microcode_ctl-1.28.tar.xz 876760 BLAKE2B 8523bdc59ab21a6ec2e1110116bfb4c7a1
EBUILD microcode-ctl-1.23.ebuild 1271 BLAKE2B 8a7adc9b789dfdadf4a44ee4301040c0047f4e68bc71d46b04acbfe2b1d9978415d6e184d328d05c39b65a37b59db34d5b274cc1168cf52e93775413862a0a0c SHA512 b5ef619c8b5821e4a52282f34e7e4880962e2d9d6f8f279f3ae7553ca5a72e28c69f4ac921b1370ea199635c63d705e89e78968ff3fe5520556c4732fbf68355
EBUILD microcode-ctl-1.27.ebuild 1273 BLAKE2B d3b5ac1888e2abce28f63f5f6d92ca4eca7b6714c1fc93ad0f304a0a790ce4c46c7bc8c73a4142b5533c233599989d6cf34347bc0adf26ab54b130b3cf659f31 SHA512 9d23c1914298105aaaf8937162cf7673a09d12dde1778c4bd99d708b09307527bafb3c45a556b78a02460aac3842001f30cf67bafadd5a64fec596013926434a
EBUILD microcode-ctl-1.28-r1.ebuild 1035 BLAKE2B e82bd192b0ee75ddeb53a1112ddcb1aa5846fe2e8c84137509fa6b723cdd4b96eb6f0d7176d83d538a86ed032f6b19bef726ac31896a2f0617d44b11c1e91a44 SHA512 a63bb4b08ada1fa9e4c114f4a7c8019201e29260282b75cc58247264602191bfe83a4076f8673bb591443f08c3e9e8723e1952f7bcf7bb0951a457572f527964
+EBUILD microcode-ctl-1.28-r2.ebuild 1147 BLAKE2B 9bb9e2be7a589eaf4ffc30ebf95bb9a6f7f38019c5b598659dc7a037fa3051673c2185df8bfc7007205436246214cb40260ae8204f2ba0876ed33350b838bf95 SHA512 c6782fc6a6919a2eda6f6b229c0498b4ff1907cee8eab2dcfdf43017a6849cc996af39202daaadf2d7093c51752984938e7c77090c4b1529b7c2c7001bbdb4aa
EBUILD microcode-ctl-1.28.ebuild 1273 BLAKE2B d3b5ac1888e2abce28f63f5f6d92ca4eca7b6714c1fc93ad0f304a0a790ce4c46c7bc8c73a4142b5533c233599989d6cf34347bc0adf26ab54b130b3cf659f31 SHA512 9d23c1914298105aaaf8937162cf7673a09d12dde1778c4bd99d708b09307527bafb3c45a556b78a02460aac3842001f30cf67bafadd5a64fec596013926434a
MISC metadata.xml 253 BLAKE2B 295e9d6d93aaa12af413972e1590c67087801cc09c9aa6b59d4606c0f4106d1dacf2baa9858559083b4c6d91beeef218d0729e8593a33788958da6d2897e8ce2 SHA512 54a9069aeb4165d2dff3d473c8001bc51613aac9dff3f7f5e9971a9891a737a31511ffa11cbd523febe581ac1d9de2bdf2f40410f0c4239138f2ccca3ef15555
diff --git a/sys-apps/microcode-ctl/microcode-ctl-1.28-r2.ebuild b/sys-apps/microcode-ctl/microcode-ctl-1.28-r2.ebuild
new file mode 100644
index 000000000000..4ca58a106615
--- /dev/null
+++ b/sys-apps/microcode-ctl/microcode-ctl-1.28-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs versionator
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Intel processor microcode update utility"
+HOMEPAGE="https://pagure.io/microcode_ctl"
+SRC_URI="https://releases.pagure.org/${PN/-/_}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="selinux"
+
+DEPEND=""
+RDEPEND=">=sys-firmware/intel-microcode-20090330[monolithic(+)]
+ selinux? ( sec-policy/selinux-cpucontrol )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dosbin microcode_ctl
+ doman microcode_ctl.8
+ dodoc Changelog README
+}
+
+pkg_preinst() {
+ local _v
+ for _v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 1.28-r1 ${_v}; then
+ # This is an upgrade
+ elog "The init scripts have been removed as they are unsafe. If you want to update"
+ elog "the microcode in your system, please use an initramfs. See bug #528712#41 for"
+ elog "details (and bug #557278 for genkernel users)."
+ fi
+
+ # Show this elog only once
+ break
+ done
+}