summaryrefslogtreecommitdiff
path: root/sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild')
-rw-r--r--sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild b/sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..76093fd584cc
--- /dev/null
+++ b/sys-apps/lmctfy/lmctfy-0.5.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Linux application container management from Google"
+HOMEPAGE="https://github.com/google/lmctfy"
+SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ dev-libs/protobuf
+ >=dev-cpp/gflags-2.1.1
+ dev-libs/re2
+ sys-libs/libapparmor
+ "
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-lang/go:=
+ "
+RDEPEND="${COMMON_DEPEND}"
+
+src_compile() {
+ # test deps take too long to compile
+ use test && emake || emake lmctfy liblmctfy.a
+}
+
+src_install() {
+ dobin bin/lmctfy/cli/lmctfy
+ dolib.a bin/liblmctfy.a
+}