summaryrefslogtreecommitdiff
path: root/sys-apps/i2c-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /sys-apps/i2c-tools
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'sys-apps/i2c-tools')
-rw-r--r--sys-apps/i2c-tools/Manifest3
-rw-r--r--sys-apps/i2c-tools/i2c-tools-4.1-r1.ebuild81
-rw-r--r--sys-apps/i2c-tools/i2c-tools-4.1.ebuild10
3 files changed, 88 insertions, 6 deletions
diff --git a/sys-apps/i2c-tools/Manifest b/sys-apps/i2c-tools/Manifest
index ce807652cd20..e1497bad9918 100644
--- a/sys-apps/i2c-tools/Manifest
+++ b/sys-apps/i2c-tools/Manifest
@@ -1,5 +1,6 @@
DIST i2c-tools-4.0.tar.xz 79972 BLAKE2B 982e4139ed0e2111f9e082d0690fcc0f86f97a433e292e9464b41991f14a1f90147a3612172bad6880f0df6896612e1dea0ae7bf6f459758b2cff45fb35a5dc7 SHA512 ddf86c357c101388193581bc40285089e6ab5e8d870f8aa5d594acc7ecb8596fbd30501e147b88bdea0200b1be88bc0a374356c188d1bcb067bf8e254e3dc51e
DIST i2c-tools-4.1.tar.xz 83576 BLAKE2B 0a9ed3bb335b61f6c17a6b6c705502ff008b4fb8bab6a5fde63163a32528b5214d92affc4b8d6cca29676dc7ba82dfa84be5f14943b7e81c8612a7d9419ac628 SHA512 83262bcfd94c2adf74517cc50095dd78221fa4d16a62397245d4a538de7463272abf4f6727024be8ab1ca8ecbfe647af85ba2a553e5b5e68a53e50dfcad20248
EBUILD i2c-tools-4.0.ebuild 1426 BLAKE2B 5ac0667c25aac0bb702b6fb4710a49f5b757900a4fd60380b044c9e106604f021d84c9b12402a12725039793fb5284467b4c14f9308842777b6539a0837a6b01 SHA512 f930853406ca01db15d14e865c0a3b9ccfca306f4ee8d094c31afecbc72cd571b33db9a07b9bb04a23c494ac19fb97dbc34c38bd003831a272dc8274981d8656
-EBUILD i2c-tools-4.1.ebuild 1537 BLAKE2B cfaf2d3e7cb5b781cf879ffce5a3fc3a0ef852425afc4c98639d67885b838e963a1544e4da80d014e39618320f52d3fec3b6a24214224d8aa336d544fc433912 SHA512 97390dca8ef3fe0b0aa3c5389ebb53de0cfc42dbe58840452028d79d77f38c75e1dea22f8152a7156863068d8aac89cfe06c9a095fee76870ab2fd504bc52168
+EBUILD i2c-tools-4.1-r1.ebuild 1952 BLAKE2B 0a228eca593741e05df7864f6540a8630d45d52f80507de525b44934f1861ee47ddfa02b721dc809ef8aeccfded3140e3ac7650e560717d35f9261a335ae0966 SHA512 a4c4d9bbcd4b070d8ab048941296d401c18671307e80853930e0c2b46ba145bb8f81e9b691208a62f86a2a30de58014b29c86ad8f900490f35341dd2705c658e
+EBUILD i2c-tools-4.1.ebuild 1548 BLAKE2B c73f668a5dc10708ff3917988a010a51db4b6128a3b360b0be6ed506f2915caec0c8f81c3c3b14eb6d7d36db0b6ccd4642eda3147ff628809f936817c75db882 SHA512 62f60c54b19108b03cc1e1c3fa440004013fa5b1acdf45e7df769745ac2fa2b518af03f292f66eddef6451053b8775b752c49669a44b4de97dbb44f03bcb40b7
MISC metadata.xml 243 BLAKE2B f7576f14be2c0aa21ca2c7147133e4a4132d6559cca1519745dd2f4ea912b3856950c7645e13d2317f38c80ba93b13d47370260920241a5ab60a4eae59f2cf33 SHA512 0dc1f228861badffd9c4175af734b72435dc7c60d369a3d9ff946c5b98b3f2f49af7d433f7ec5fc2afee7015b8f75259e8debe150b1bcffa0cb66425bed10d8d
diff --git a/sys-apps/i2c-tools/i2c-tools-4.1-r1.ebuild b/sys-apps/i2c-tools/i2c-tools-4.1-r1.ebuild
new file mode 100644
index 000000000000..2127072c21bb
--- /dev/null
+++ b/sys-apps/i2c-tools/i2c-tools-4.1-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+DISTUTILS_OPTIONAL="1"
+
+inherit distutils-r1 flag-o-matic toolchain-funcs
+
+DESCRIPTION="I2C tools for bus probing, chip dumping, EEPROM decoding, and more"
+HOMEPAGE="https://www.kernel.org/pub/software/utils/i2c-tools"
+SRC_URI="${HOMEPAGE}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="perl python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="!<sys-apps/lm_sensors-3
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+RDEPEND+="
+ perl? ( dev-lang/perl )"
+
+src_prepare() {
+ default
+ use python && distutils-r1_src_prepare
+
+ # Cut out the eeprom/ & stub/ dirs as only perl scripts live there.
+ if ! use perl ; then
+ sed -i '/^SRCDIRS/s: eeprom stub : :g' Makefile || die
+ fi
+}
+
+src_configure() {
+ use python && distutils-r1_src_configure
+
+ # Always build & use dynamic libs if possible.
+ if tc-is-static-only ; then
+ export BUILD_DYNAMIC_LIB=0
+ export USE_STATIC_LIB=1
+ export BUILD_STATIC_LIB=1
+ else
+ export BUILD_DYNAMIC_LIB=1
+ export USE_STATIC_LIB=0
+ export BUILD_STATIC_LIB=$(usex static-libs 1 0)
+ fi
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" all-lib # parallel make
+ emake CC="$(tc-getCC)"
+ emake -C eepromer CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+
+ if use python ; then
+ cd py-smbus || die
+ append-cppflags -I../include
+ distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" libdir="/usr/$(get_libdir)" PREFIX="/usr" install-lib install
+ dosbin eepromer/eeprom{,er}
+ rm -rf "${D}"/usr/include || die # part of linux-headers
+ dodoc CHANGES README
+ local d
+ for d in $(usex perl eeprom '') eepromer ; do
+ docinto "${d}"
+ dodoc "${d}"/README*
+ done
+
+ if use python ; then
+ cd py-smbus || die
+ docinto py-smbus
+ dodoc README*
+ distutils-r1_src_install
+ fi
+}
diff --git a/sys-apps/i2c-tools/i2c-tools-4.1.ebuild b/sys-apps/i2c-tools/i2c-tools-4.1.ebuild
index f87aa062cf91..f3549776e8e3 100644
--- a/sys-apps/i2c-tools/i2c-tools-4.1.ebuild
+++ b/sys-apps/i2c-tools/i2c-tools-4.1.ebuild
@@ -32,9 +32,9 @@ src_configure() {
}
src_compile() {
- emake AR=$(tc-getAR) CC=$(tc-getCC) all-lib # parallel make
- emake CC=$(tc-getCC)
- emake -C eepromer CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" all-lib # parallel make
+ emake CC="$(tc-getCC)"
+ emake -C eepromer CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
if use python ; then
cd py-smbus || die
@@ -50,8 +50,8 @@ src_install() {
dodoc CHANGES README
local d
for d in eeprom eepromer ; do
- docinto ${d}
- dodoc ${d}/README*
+ docinto "${d}"
+ dodoc "${d}"/README*
done
if use python ; then