summaryrefslogtreecommitdiff
path: root/sys-apps/ethtool/ethtool-5.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /sys-apps/ethtool/ethtool-5.8-r1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'sys-apps/ethtool/ethtool-5.8-r1.ebuild')
-rw-r--r--sys-apps/ethtool/ethtool-5.8-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/ethtool/ethtool-5.8-r1.ebuild b/sys-apps/ethtool/ethtool-5.8-r1.ebuild
new file mode 100644
index 000000000000..f1dae680c309
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-5.8-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
+IUSE="+netlink"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="netlink? ( net-libs/libmnl )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.8-avoid_bashisms.patch"
+ "${FILESDIR}/${P}-only-memset-non-NULL-link-settings.patch"
+)
+
+src_configure() {
+ econf $(use_enable netlink)
+}