summaryrefslogtreecommitdiff
path: root/sci-visualization/fityk/fityk-1.2.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-visualization/fityk/fityk-1.2.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-visualization/fityk/fityk-1.2.9.ebuild')
-rw-r--r--sci-visualization/fityk/fityk-1.2.9.ebuild92
1 files changed, 92 insertions, 0 deletions
diff --git a/sci-visualization/fityk/fityk-1.2.9.ebuild b/sci-visualization/fityk/fityk-1.2.9.ebuild
new file mode 100644
index 000000000000..b1fc0d146d49
--- /dev/null
+++ b/sci-visualization/fityk/fityk-1.2.9.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit autotools-utils fdo-mime python-r1 wxwidgets
+
+DESCRIPTION="General-purpose nonlinear curve fitting and data analysis"
+HOMEPAGE="http://fityk.nieto.pl/"
+SRC_URI="https://github.com/wojdyr/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="gnuplot nlopt readline python static-libs wxwidgets"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+CDEPEND="
+ >=sci-libs/xylib-1
+ >=dev-lang/lua-5.1:0
+ nlopt? ( sci-libs/nlopt )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:* )
+ wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER} )"
+DEPEND="${CDEPEND}
+ dev-libs/boost
+ dev-lang/swig"
+RDEPEND="${CDEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+src_prepare() {
+ use python && python_copy_sources
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --disable-xyconvert
+ --disable-python
+ $(use_enable nlopt)
+ $(use_enable wxwidgets GUI)
+ $(use_with readline)
+ )
+ autotools-utils_src_configure
+ if use python; then
+ myeconfargs=(
+ --disable-xyconvert
+ --enable-python
+ --disable-nlopt
+ --disable-GUI
+ --without-readline )
+ python_foreach_impl autotools-utils_src_configure
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use python; then
+ python_compilation() {
+ cd "${BUILD_DIR}"/fityk || die
+ einfo "in ${PWD}"
+ emake swig/_fityk.la
+ }
+ python_foreach_impl python_compilation
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use python; then
+ python_installation() {
+ cd "${BUILD_DIR}"/fityk || die
+ emake DESTDIR="${D}" install-pyexecLTLIBRARIES
+ rm "${D}"/$(python_get_sitedir)/*.la || die
+ }
+ python_foreach_impl python_installation
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}