summaryrefslogtreecommitdiff
path: root/sci-libs/composable-kernel/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-27 07:59:40 +0100
commitd2ed973482fdd800013658e83a61709b29e0a80f (patch)
tree57ea7666a57b5a05a4c8866e4915e90b4a6e7c94 /sci-libs/composable-kernel/files
parent9f6a82a85d400d6ae7de04c43cee88dbc6bc4da0 (diff)
gentoo auto-resync : 27:06:2024 - 07:59:39
Diffstat (limited to 'sci-libs/composable-kernel/files')
-rw-r--r--sci-libs/composable-kernel/files/composable-kernel-6.1.1-enable-examples.patch14
-rw-r--r--sci-libs/composable-kernel/files/composable-kernel-6.1.1-fix-clang-17-no-offload-uniform-block.patch18
-rw-r--r--sci-libs/composable-kernel/files/composable-kernel-6.1.1-no-git-no-hash.patch14
3 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/composable-kernel/files/composable-kernel-6.1.1-enable-examples.patch b/sci-libs/composable-kernel/files/composable-kernel-6.1.1-enable-examples.patch
new file mode 100644
index 000000000000..bedc79c562bd
--- /dev/null
+++ b/sci-libs/composable-kernel/files/composable-kernel-6.1.1-enable-examples.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -470,7 +470,10 @@ if(NOT DEFINED INSTANCES_ONLY)
+ LIBRARY_NAME composablekernel
+ PACKAGE_NAME examples
+ )
+- add_subdirectory(example)
++ option(BUILD_EXAMPLES "Build examples" OFF)
++ if(BUILD_EXAMPLES)
++ add_subdirectory(example)
++ endif()
+ if(BUILD_TESTING)
+ add_subdirectory(test)
+ endif()
diff --git a/sci-libs/composable-kernel/files/composable-kernel-6.1.1-fix-clang-17-no-offload-uniform-block.patch b/sci-libs/composable-kernel/files/composable-kernel-6.1.1-fix-clang-17-no-offload-uniform-block.patch
new file mode 100644
index 000000000000..3a102bec49cd
--- /dev/null
+++ b/sci-libs/composable-kernel/files/composable-kernel-6.1.1-fix-clang-17-no-offload-uniform-block.patch
@@ -0,0 +1,18 @@
+`-fno-offload-uniform-block` flag was added in Clang 18; do not use it if hipcc uses Clang 17
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -144,11 +144,9 @@ else()
+ message("Building CK for the following targets: ${AMDGPU_TARGETS}")
+ endif()
+ find_package(hip)
+-# No assumption that HIP kernels are launched with uniform block size for backward compatibility
+-# SWDEV-413293 and https://reviews.llvm.org/D155213
+-math(EXPR hip_VERSION_FLAT "(${hip_VERSION_MAJOR} * 1000 + ${hip_VERSION_MINOR}) * 100000 + ${hip_VERSION_PATCH}")
+-message("hip_version_flat=${hip_VERSION_FLAT}")
+-if(NOT WIN32 AND ${hip_VERSION_FLAT} GREATER 500723302)
++
++check_cxx_compiler_flag("-x hip -fno-offload-uniform-block" COMPILER_HAS_OPTION_OFFLOAD_UNIFORM_BLOCK)
++if(COMPILER_HAS_OPTION_OFFLOAD_UNIFORM_BLOCK)
+ message("Adding the fno-offload-uniform-block compiler flag")
+ add_compile_options(-fno-offload-uniform-block)
+ endif()
diff --git a/sci-libs/composable-kernel/files/composable-kernel-6.1.1-no-git-no-hash.patch b/sci-libs/composable-kernel/files/composable-kernel-6.1.1-no-git-no-hash.patch
new file mode 100644
index 000000000000..6c6b161b1a14
--- /dev/null
+++ b/sci-libs/composable-kernel/files/composable-kernel-6.1.1-no-git-no-hash.patch
@@ -0,0 +1,14 @@
+Fix "Could NOT find Git (missing: GIT_EXECUTABLE)", git is not needed for releases
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -84,9 +84,7 @@ include(getopt)
+ # CK config file to record supported datatypes, etc.
+ configure_file(include/ck/config.h.in ${CMAKE_CURRENT_BINARY_DIR}/include/ck/config.h)
+
+-# CK version file to record release version as well as git commit hash
+-find_package(Git REQUIRED)
+-execute_process(COMMAND "${GIT_EXECUTABLE}" rev-parse HEAD OUTPUT_VARIABLE COMMIT_ID OUTPUT_STRIP_TRAILING_WHITESPACE)
++# CK version file to record release version
+ configure_file(include/ck/version.h.in ${CMAKE_CURRENT_BINARY_DIR}/include/ck/version.h)
+
+ set(ROCM_SYMLINK_LIBS OFF)