summaryrefslogtreecommitdiff
path: root/sci-geosciences/gpsd/gpsd-3.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /sci-geosciences/gpsd/gpsd-3.21.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'sci-geosciences/gpsd/gpsd-3.21.ebuild')
-rw-r--r--sci-geosciences/gpsd/gpsd-3.21.ebuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/sci-geosciences/gpsd/gpsd-3.21.ebuild b/sci-geosciences/gpsd/gpsd-3.21.ebuild
index 6cbd9be5a865..c5109b205bda 100644
--- a/sci-geosciences/gpsd/gpsd-3.21.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.21.ebuild
@@ -6,14 +6,14 @@ EAPI=7
DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{6..9} )
-inherit eutils udev multilib distutils-r1 scons-utils toolchain-funcs
+inherit distutils-r1 scons-utils toolchain-funcs udev
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://gitlab.com/gpsd/gpsd.git"
inherit git-r3
else
SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="amd64 arm ~ppc ~ppc64 ~sparc x86"
fi
DESCRIPTION="GPS daemon and library for USB/serial GPS devices and GPS/mapping clients"
@@ -94,13 +94,18 @@ src_prepare() {
-e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
SConstruct || die
- #Fix systemd binary paths
- sed -i -e 's/local\///' 'systemd/gpsd.service'
- sed -i -e 's/local\///' 'systemd/gpsdctl@.service.in'
+ # Fix systemd binary paths
+ sed -i -e 's/local\///' 'systemd/gpsd.service' || die
+ sed -i -e 's/local\///' 'systemd/gpsdctl@.service.in' || die
default
- use python && distutils-r1_src_prepare
+ if use python ; then
+ distutils-r1_src_prepare
+ else
+ # We're using escons, bug #734352
+ python_setup
+ fi
}
python_prepare_all() {
@@ -185,8 +190,11 @@ src_install() {
newinitd "${FILESDIR}"/gpsd.init-2 gpsd
# Cleanup bad alt copy due to Scons
- rm -rf "${D}"/python-discard/gps*
- find "${D}"/python-discard/ -type d -delete
+ if use python ; then
+ rm -rf "${ED}"/python-discard/gps* || die
+ find "${ED}"/python-discard/ -type d -delete || die
+ fi
+
# Install correct multi-python copy
use python && distutils-r1_src_install
}