summaryrefslogtreecommitdiff
path: root/sci-electronics/Stage/Stage-4.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sci-electronics/Stage/Stage-4.3.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sci-electronics/Stage/Stage-4.3.0.ebuild')
-rw-r--r--sci-electronics/Stage/Stage-4.3.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-electronics/Stage/Stage-4.3.0.ebuild b/sci-electronics/Stage/Stage-4.3.0.ebuild
new file mode 100644
index 000000000000..959166dc2194
--- /dev/null
+++ b/sci-electronics/Stage/Stage-4.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/rtv/Stage"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/rtv/Stage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="The Stage Robot Simulator"
+HOMEPAGE="http://rtv.github.io/Stage/"
+LICENSE="GPL-2"
+SLOT="0/4.3"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libltdl:0
+ virtual/jpeg:0
+ media-libs/libpng:0=
+ sys-libs/zlib:0=
+ x11-libs/fltk[opengl]
+ virtual/glu
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+PATCHES=( "${FILESDIR}/libdir.patch" )