summaryrefslogtreecommitdiff
path: root/ros-meta/roscpp_core/roscpp_core-0.6.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /ros-meta/roscpp_core/roscpp_core-0.6.9.ebuild
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'ros-meta/roscpp_core/roscpp_core-0.6.9.ebuild')
-rw-r--r--ros-meta/roscpp_core/roscpp_core-0.6.9.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/ros-meta/roscpp_core/roscpp_core-0.6.9.ebuild b/ros-meta/roscpp_core/roscpp_core-0.6.9.ebuild
new file mode 100644
index 000000000000..c4465ab79b4d
--- /dev/null
+++ b/ros-meta/roscpp_core/roscpp_core-0.6.9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Underlying data libraries for roscpp messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/roscpp_traits
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}"