summaryrefslogtreecommitdiff
path: root/net-nds/yp-tools/yp-tools-4.2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-02 21:07:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-02 21:07:25 +0000
commit27dfd272ae3be15b1017f733682211afa1c7c0f0 (patch)
tree1fe1c9ed5c5d79c63069bb8d541be075ccc3aac2 /net-nds/yp-tools/yp-tools-4.2.2-r1.ebuild
parentd950fa39dbe16d164ed0cb8e3036fd5d0d896a4c (diff)
gentoo resync : 02.11.2017
Diffstat (limited to 'net-nds/yp-tools/yp-tools-4.2.2-r1.ebuild')
-rw-r--r--net-nds/yp-tools/yp-tools-4.2.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-nds/yp-tools/yp-tools-4.2.2-r1.ebuild b/net-nds/yp-tools/yp-tools-4.2.2-r1.ebuild
new file mode 100644
index 000000000000..85e54c36ba59
--- /dev/null
+++ b/net-nds/yp-tools/yp-tools-4.2.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit systemd
+
+DESCRIPTION="Network Information Service tools"
+HOMEPAGE="http://www.linux-nis.org/nis/"
+SRC_URI="http://www.linux-nis.org/download/yp-tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="
+ || ( <sys-libs/glibc-2.26[rpc] net-libs/libtirpc )
+ net-libs/libnsl:0=
+"
+RDEPEND=${DEPEND}
+# uses always libtirpc if present
+
+src_configure () {
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/yp \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ insinto /etc/yp
+ doins etc/nicknames
+
+ systemd_dounit "${FILESDIR}/domainname.service"
+ systemd_install_serviced "${FILESDIR}"/domainname.service.conf
+}