summaryrefslogtreecommitdiff
path: root/net-misc/ncp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /net-misc/ncp
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'net-misc/ncp')
-rw-r--r--net-misc/ncp/Manifest3
-rw-r--r--net-misc/ncp/metadata.xml15
-rw-r--r--net-misc/ncp/ncp-1.2.4-r1.ebuild42
3 files changed, 55 insertions, 5 deletions
diff --git a/net-misc/ncp/Manifest b/net-misc/ncp/Manifest
index 80711f91735c..4c369dfb98f3 100644
--- a/net-misc/ncp/Manifest
+++ b/net-misc/ncp/Manifest
@@ -1,3 +1,4 @@
DIST ncp-1.2.4.tar.bz2 6172 BLAKE2B f1daea93f56013bff8bcf3fa58155b4cce3451a834bfc7c066d1accc0cdb4c874f09761e2b1eaf70c2034aede41bfb89598659e0d083fc21d75fd7e25e71f038 SHA512 7332cffef56ec8dd8afefbb3f3dda455bc4465a61476cb7a751f9fa0b9cc1c125e22f1d89b9cab36e059f3f686c8dcc847015c4a44c23dd5bca8290b5666bdc8
+EBUILD ncp-1.2.4-r1.ebuild 843 BLAKE2B d42afa30ebcb9b390ff02b964f66353cd00ece303168645ccb4dd2ab85339e66b968b496fa8fd230b38da87c877a2e0f39085a333f7371686cc9ae6a861cbaad SHA512 3cb657dd0c5eba849d352eccb6b880df6660c854e98883b7ba1f9c054d677fcbd1ff812001cbc138893369dc5f5b57a352ad17d0fcd6ae1a9295291665af4186
EBUILD ncp-1.2.4.ebuild 853 BLAKE2B 24aec6cd73be1471ef9ca3a7f9da8cf0e6a11cd78ed4eebb6390d9edabe66ddbc62825410e5996c850a41aac639055f167416af8b17f464ccc078b59d1d3b796 SHA512 b7495762fa68ceb0927159dd65f000fc062fdfdcc5f50f1333ce68e43ce4e32db899e16d538b74bcf366a3deff49e1e73ec796e6df41ba8ebc1e544b94849316
-MISC metadata.xml 487 BLAKE2B 2dba73139b43435aa6bc2cdbc667e615639de51f827ff1c114f6c94189c9b9e0279d0dbff1b48ea69680273b15b5f35bdd63dbb51b69538f361f5064d61f44ef SHA512 2be2a4fbddaec2fbeab193db226542ab35dc7fa51231c6b6fb55284b521c8c5afe9ea9cc5ada2cf1663cd87a8abdd8213c304e3c2dbf5795b1d4e8b5b956dce5
+MISC metadata.xml 698 BLAKE2B 4e878fa6c8542b522a34bd256345a93060d5b64fc539f59dc5db207680dab597fba92beb7361bd002afca64dd291c2ba1053a435cc2b1ad35bba878a81d00bec SHA512 deb18945b820f2332812f851dd4d1a40dddca5fd04541987746d2c3a9d75a25792ce8fb1931e8c87010a73f820165155172d2aeb2d2d702cc95a3a1b8e34b169
diff --git a/net-misc/ncp/metadata.xml b/net-misc/ncp/metadata.xml
index f0915952f0fb..da384e181f0e 100644
--- a/net-misc/ncp/metadata.xml
+++ b/net-misc/ncp/metadata.xml
@@ -1,9 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription lang="en">
+ <maintainer type="person">
+ <email>bu9zilla@gmail.com</email>
+ <name>Michael Mair-Keimberger</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
"ncp" is a utility for copying files in a LAN. It has absolutely no security or integrity checking, no throttling, no features, except one: you don't have to type the coordinates of your peer.
-</longdescription>
-<use><flag name="diet">Compile against <pkg>dev-libs/dietlibc</pkg></flag></use>
+ </longdescription>
+ <use><flag name="diet">Compile against <pkg>dev-libs/dietlibc</pkg></flag></use>
</pkgmetadata>
diff --git a/net-misc/ncp/ncp-1.2.4-r1.ebuild b/net-misc/ncp/ncp-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..6309febf0296
--- /dev/null
+++ b/net-misc/ncp/ncp-1.2.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility for copying files in a LAN (npoll, npush)"
+HOMEPAGE="https://www.fefe.de/ncp/"
+SRC_URI="https://dl.fefe.de/${P}.tar.bz2"
+
+LICENSE="public-domain" # mail from author, bug 446540
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="diet"
+
+DEPEND=">=dev-libs/libowfat-0.28-r1
+ diet? ( dev-libs/dietlibc )"
+
+src_prepare() {
+ default
+ rm Makefile || die
+ sed -e '/^ncp:/,+5s:strip:#strip:' \
+ -i GNUmakefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(use diet && echo "diet -Os ")$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I/usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" \
+ STRIP="#"
+}
+
+src_install() {
+ dobin ${PN}
+ dosym ${PN} /usr/bin/npoll
+ dosym ${PN} /usr/bin/npush
+
+ doman ncp.1 npush.1
+ dodoc NEWS
+}