summaryrefslogtreecommitdiff
path: root/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-06 00:00:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-06 00:00:52 +0100
commit43c2a85d4e20318dd3d35872e348707900870067 (patch)
treef863318f1d5bf6641145c6eb96a25818842ba87f /net-misc/connman-json-client/connman-json-client-1.0_p20150721-r3.ebuild
parentb594445f39d99066071d80fc8efeba5c8f72cc35 (diff)
gentoo auto-resync : 06:05:2024 - 00:00:51
Diffstat (limited to 'net-misc/connman-json-client/connman-json-client-1.0_p20150721-r3.ebuild')
-rw-r--r--net-misc/connman-json-client/connman-json-client-1.0_p20150721-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r3.ebuild b/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r3.ebuild
new file mode 100644
index 000000000000..c5fed0b76125
--- /dev/null
+++ b/net-misc/connman-json-client/connman-json-client-1.0_p20150721-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools vcs-snapshot
+COMMIT="3c34b2ee62d2e188090d20e7ed2fd94bab9c47f2"
+
+DESCRIPTION="An ncurses UI for connman"
+HOMEPAGE="https://github.com/eurogiciel-oss/connman-json-client"
+SRC_URI="https://github.com/eurogiciel-oss/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/json-c:0=
+ >=sys-apps/dbus-1.4
+ sys-libs/ncurses:0"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/cjc-fix-for-json-0.14.patch )
+
+src_prepare() {
+ sed -i -e '/^AM_CFLAGS/ s/ -Werror$//' Makefile.am || die
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+ dobin connman_ncurses
+}