summaryrefslogtreecommitdiff
path: root/net-libs/libtorrent-rasterbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 11:49:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 11:49:23 +0000
commit840a65e2af3f2cc7527e723a28f6e627a9592fb7 (patch)
tree66e124d9e55317fe43e1af9984e75c156df5cb29 /net-libs/libtorrent-rasterbar
parent73e3b099187df1c4f2df056e45f345a56d2535aa (diff)
gentoo auto-resync : 30:01:2024 - 11:49:23
Diffstat (limited to 'net-libs/libtorrent-rasterbar')
-rw-r--r--net-libs/libtorrent-rasterbar/Manifest1
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.9-r1.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/Manifest b/net-libs/libtorrent-rasterbar/Manifest
index 0cd41e97add9..0c97fecb1f10 100644
--- a/net-libs/libtorrent-rasterbar/Manifest
+++ b/net-libs/libtorrent-rasterbar/Manifest
@@ -5,5 +5,6 @@ DIST libtorrent-rasterbar-2.0.9.tar.gz 4720611 BLAKE2B 54de2dfba2bdc6c4341fddc54
EBUILD libtorrent-rasterbar-1.2.18-r1.ebuild 1789 BLAKE2B 863906064e168b1c7a4856607153e17ffd4714096b0ff4d3cff44663a9af9a677f19e27745ead1d42824bf7a592e3dac60d8620747b37da69fae7d155b1fe4c7 SHA512 e38953c0946835bdc36ed6d8d80ac31eb199189446cd419c3d2588a9d270a2b0e9adb13b1d450fa0f5866475fd131787099b9203eb4c323c9d0fd7dd97042995
EBUILD libtorrent-rasterbar-1.2.19.ebuild 1791 BLAKE2B dce4a514f28b0b8d0015b01f0342134aedc4214482cb625de0c593208098fc7d4d41bd751b2380a7d3144c522fe84c508556b1448787cc2d55c43bd8bb470a02 SHA512 82b234329999fba3acd54fbe722d935fa439f99a9ee3378d1b4fbaa7ca62139f4729a87b4b4111df9f14be885b624d6aae1ae6012834596014c2e1fba200e1db
EBUILD libtorrent-rasterbar-2.0.8.ebuild 1893 BLAKE2B 2a22bc1340ea847a8f5a8aaf0e420a4c108ace8acd4b1275a283f8c93c5fd2855e83652abaa5722c2e984ef763832f90abb2b8d4948f7939178acb5bbcab73d4 SHA512 aea9aca9595497b5f54ffec4def5ed4d6b6f5a7e747b3e8447d83580dcd62c24a91225a3cdb3ed2ee23971c276787f7664fce9756d24aefe2da27d4e140b430e
+EBUILD libtorrent-rasterbar-2.0.9-r1.ebuild 2690 BLAKE2B 4643e9bbf4207253764c4feace6558d7baac041d97d74086c1382dc0d084ac4fdd19b309a5f22b02d09016b5414ef9c50a4dd031fea97383f1e49994ee4eb692 SHA512 2e6b1f0d4a43aafffa0b1581be4aeacaae719eda5a0307b102a8ee281ebd734b16c077aafe56b73cc2a79ea83c5a403d50bd95803aa5503829a0a4ddf8322b09
EBUILD libtorrent-rasterbar-2.0.9.ebuild 1893 BLAKE2B 2a22bc1340ea847a8f5a8aaf0e420a4c108ace8acd4b1275a283f8c93c5fd2855e83652abaa5722c2e984ef763832f90abb2b8d4948f7939178acb5bbcab73d4 SHA512 aea9aca9595497b5f54ffec4def5ed4d6b6f5a7e747b3e8447d83580dcd62c24a91225a3cdb3ed2ee23971c276787f7664fce9756d24aefe2da27d4e140b430e
MISC metadata.xml 445 BLAKE2B f15fb3002e1a5f205ad22b4cd3969da7e0cd48471a3b6f2235d47aa754014867f84cb41269e620df154beb4ad4f046dc77e3638244a1b45a33f9097613f49dd3 SHA512 94b12e4317a8633fe7d39fe49a6b69d271b7f77510e42cbd1cb44e3720437d3521fa815a09513cd84a8d0ded88d55f9ca8e4e29e49a94ff605e198b7f04e9462
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.9-r1.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.9-r1.ebuild
new file mode 100644
index 000000000000..a2451165ead0
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.9-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# no 3.12 for now
+# https://github.com/arvidn/libtorrent/commit/785969574cfe925098f50b7e5d9ae2a9f2a9d0cf
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="https://libtorrent.org/ https://github.com/arvidn/libtorrent"
+SRC_URI="https://github.com/arvidn/libtorrent/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+dht debug examples gnutls python ssl test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/boost:=
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-libs/boost[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+BDEPEND="
+ dev-util/patchelf
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
+ )
+ test? (
+ ${PYTHON_DEPS}
+ )
+"
+
+pkg_setup() {
+ # python required for tests due to webserver.py
+ if use python || use test; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_CXX_STANDARD=17
+ -DBUILD_SHARED_LIBS=ON
+ -Dbuild_examples=$(usex examples)
+ -Ddht=$(usex dht)
+ -Dencryption=$(usex ssl)
+ -Dgnutls=$(usex gnutls)
+ -Dlogging=$(usex debug)
+ -Dpython-bindings=$(usex python)
+ -Dbuild_tests=$(usex test)
+ )
+
+ # We need to drop the . from the Python version to satisfy Boost's
+ # FindBoost.cmake module, bug #793038.
+ use python && mycmakeargs+=( -Dboost-python-module-name="${EPYTHON/./}" )
+
+ cmake_src_configure
+}
+
+src_test() {
+ CMAKE_SKIP_TESTS=(
+ # Needs running UPnP server
+ "test_upnp"
+ # Missing files in 2.0.9 release archive
+ # https://github.com/arvidn/libtorrent/issues/7567
+ "test_create_torrent"
+ # Certificates outdated
+ # https://github.com/arvidn/libtorrent/issues/7565
+ "test_ssl"
+ # Fragile to parallelization
+ # https://bugs.gentoo.org/854603#c1
+ "test_utp"
+ # Fails in tmpfs
+ # https://github.com/arvidn/libtorrent/issues/7566
+ "test_copy_file"
+ )
+
+ LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}" cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+ einstalldocs
+
+ if use examples; then
+ pushd "${BUILD_DIR}"/examples >/dev/null || die
+ for binary in {client_test,connection_tester,custom_storage,dump_bdecode,dump_torrent,make_torrent,simple_client,stats_counters,upnp_test}; do
+ patchelf --remove-rpath ${binary} || die
+ dobin ${binary}
+ done
+ popd >/dev/null || die
+ fi
+}