summaryrefslogtreecommitdiff
path: root/net-irc/weechat/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /net-irc/weechat/files
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'net-irc/weechat/files')
-rw-r--r--net-irc/weechat/files/weechat-2.2-tinfo.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-irc/weechat/files/weechat-2.2-tinfo.patch b/net-irc/weechat/files/weechat-2.2-tinfo.patch
new file mode 100644
index 000000000000..aee651911ce7
--- /dev/null
+++ b/net-irc/weechat/files/weechat-2.2-tinfo.patch
@@ -0,0 +1,28 @@
+Use pkgconfig to find ncurses libs in order to support separate libtinfo.
+
+--- weechat-2.1/src/gui/curses/normal/CMakeLists.txt
++++ weechat-2.1/src/gui/curses/normal/CMakeLists.txt
+@@ -32,7 +32,13 @@
+ ../gui-curses-window.c
+ )
+
+-find_package(Ncurses)
++find_package(PkgConfig)
++pkg_search_module(NCURSES ncursesw ncurses)
++
++if(NOT NCURSES_FOUND)
++ find_package(Ncurses)
++endif(NOT NCURSES_FOUND)
++
+ if(NCURSES_FOUND)
+ check_include_files(ncursesw/ncurses.h NCURSESW_HEADERS)
+ if(NCURSESW_HEADERS)
+@@ -57,7 +63,7 @@
+
+ add_dependencies(${EXECUTABLE} weechat_gui_curses_normal)
+
+-list(APPEND EXTRA_LIBS ${NCURSES_LIBRARY})
++list(APPEND EXTRA_LIBS ${NCURSES_LIBRARY} ${NCURSES_LIBRARIES})
+
+ # Due to circular references, we must link two times with libweechat_core.a and libweechat_gui_common.a
+ target_link_libraries(${EXECUTABLE} ${STATIC_LIBS} weechat_gui_curses_normal ${EXTRA_LIBS} ${STATIC_LIBS})