summaryrefslogtreecommitdiff
path: root/net-irc/scrollz/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-irc/scrollz/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-irc/scrollz/files')
-rw-r--r--net-irc/scrollz/files/scrollz-2.2-cppflags.patch26
-rw-r--r--net-irc/scrollz/files/scrollz-2.2-make-install.patch24
2 files changed, 50 insertions, 0 deletions
diff --git a/net-irc/scrollz/files/scrollz-2.2-cppflags.patch b/net-irc/scrollz/files/scrollz-2.2-cppflags.patch
new file mode 100644
index 000000000000..a6727544eca5
--- /dev/null
+++ b/net-irc/scrollz/files/scrollz-2.2-cppflags.patch
@@ -0,0 +1,26 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: [PATCH] Respect CPPFLAGS.
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -68,7 +68,7 @@
+ IRCDOC = ${IRCSHARE}/doc
+
+ CC = @CC@
+-DEFS = @DEFS@
++DEFS = @DEFS@ @CPPFLAGS@
+ LIBS = @LIBS@
+
+ # Set this to -g if you want to be able to debug the client, otherwise
+
+--- a/source/Makefile.in
++++ b/source/Makefile.in
+@@ -11,7 +11,7 @@
+ LDFLAGS = @LDFLAGS@
+ LEX = @LEX@
+ LEXLIB = @LEXLIB@
+-DEFS = @DEFS@
++DEFS = @DEFS@ @CPPFLAGS@
+ LN = @LN@
+ RM = @RM@
+
diff --git a/net-irc/scrollz/files/scrollz-2.2-make-install.patch b/net-irc/scrollz/files/scrollz-2.2-make-install.patch
new file mode 100644
index 000000000000..f5591f2a8212
--- /dev/null
+++ b/net-irc/scrollz/files/scrollz-2.2-make-install.patch
@@ -0,0 +1,24 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Date: 2011-01-03
+Subject: [PATCH] Fix parallel make install.
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -179,7 +179,7 @@
+ @(cd $(DESTDIR)/$(bindir) ; $(LN) scrollz-$(VERSION) scrollz)
+ @cp doc/ScrollZ.doc $(DESTDIR)/$(IRCDOC)
+
+-installman: scrollz.1
++installman: installdirs scrollz.1
+ $(INSTALL) scrollz.1 $(DESTDIR)/$(mandir)
+
+ installserv: installio
+@@ -197,7 +197,7 @@
+ $(DESTDIR)/$(INSTALL_SCRIPT) \
+ $(DESTDIR)/$(HELP_DIR) $(DESTDIR)/$(IRCDOC) $(DESTDIR)/$(mandir)
+
+-installhelp:
++installhelp: installdirs
+ $(INSTALL_HELP_CMD)
+ find $(DESTDIR)/$(HELP_DIR) -type d -print | xargs chmod a+rx
+ find $(DESTDIR)/$(HELP_DIR) -type f -print | xargs chmod a+r