summaryrefslogtreecommitdiff
path: root/net-firewall/firehol/firehol-3.1.6-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-firewall/firehol/firehol-3.1.6-r3.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-firewall/firehol/firehol-3.1.6-r3.ebuild')
-rw-r--r--net-firewall/firehol/firehol-3.1.6-r3.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/net-firewall/firehol/firehol-3.1.6-r3.ebuild b/net-firewall/firehol/firehol-3.1.6-r3.ebuild
new file mode 100644
index 000000000000..d68ed4f8bcc6
--- /dev/null
+++ b/net-firewall/firehol/firehol-3.1.6-r3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+DESCRIPTION="iptables firewall generator"
+HOMEPAGE="https://firehol.org/ https://github.com/firehol/firehol"
+SRC_URI="https://github.com/firehol/firehol/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc ipv6 ipset"
+KEYWORDS="amd64 arm ~arm64 ~ppc ~x86"
+
+RDEPEND="net-firewall/iptables
+ sys-apps/iproute2[-minimal,ipv6(+)?]
+ sys-apps/kmod[tools]
+ net-misc/iputils[ipv6(+)?]
+ net-misc/iprange
+ net-analyzer/traceroute
+ app-arch/gzip
+ ipset? (
+ net-firewall/ipset
+ )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ local CONFIG_CHECK=" \
+ ~IP_NF_FILTER \
+ ~IP_NF_IPTABLES \
+ ~IP_NF_MANGLE \
+ ~IP_NF_TARGET_MASQUERADE
+ ~IP_NF_TARGET_REDIRECT \
+ ~IP_NF_TARGET_REJECT \
+ ~NETFILTER_XT_CONNMARK \
+ ~NETFILTER_XT_MATCH_HELPER \
+ ~NETFILTER_XT_MATCH_LIMIT \
+ ~NETFILTER_XT_MATCH_OWNER \
+ ~NETFILTER_XT_MATCH_STATE \
+ ~NF_CONNTRACK \
+ ~NF_CONNTRACK_IPV4 \
+ ~NF_CONNTRACK_MARK \
+ ~NF_NAT \
+ ~NF_NAT_FTP \
+ ~NF_NAT_IRC \
+ "
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --disable-vnetbuild \
+ $(use_enable ipset update-ipsets) \
+ $(use_enable doc) \
+ $(use_enable ipv6)
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}"/firehol.confd firehol
+ newinitd "${FILESDIR}"/firehol.initd firehol
+ newconfd "${FILESDIR}"/fireqos.confd fireqos
+ newinitd "${FILESDIR}"/fireqos.initd fireqos
+}