summaryrefslogtreecommitdiff
path: root/media-sound/spotify-tray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /media-sound/spotify-tray
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'media-sound/spotify-tray')
-rw-r--r--media-sound/spotify-tray/Manifest3
-rw-r--r--media-sound/spotify-tray/metadata.xml12
-rw-r--r--media-sound/spotify-tray/spotify-tray-1.3.1.ebuild28
3 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/spotify-tray/Manifest b/media-sound/spotify-tray/Manifest
new file mode 100644
index 000000000000..e502262391fc
--- /dev/null
+++ b/media-sound/spotify-tray/Manifest
@@ -0,0 +1,3 @@
+DIST spotify-tray-1.3.1.tar.gz 22084 BLAKE2B ee8f269d1ac618794eee8a67b814f689f3a65f18433a1e3c2382465a2b9b247e70e16fb43f061d1c7cef9188f116d0c7e8478fe3ffe2ab5f2de54dc8ccb40808 SHA512 c1fd533e3879f2d9e451264969bc797c6b8ca35f191460d40822728fc6b637ec7487154b0794871f25cbd6e01b16c7ff5eb33806a1235ac09e45e49580d1337a
+EBUILD spotify-tray-1.3.1.ebuild 617 BLAKE2B 1432cf1f86e45e202469cd5a5bb667705f6e762ac8be11787624b426ece6ff0f0e00dbcb4ebc4fd234c78ad296a2c0fbd5f7e70702e6abc36847491dd8b97c2a SHA512 063603de63effcab6223b13378c5ff781e78b0cb9a9e70dcbf0c6a75a5483e33cab5c199e8bfd6fbb8ecca5efde50275bcff5e4f3598e4a99da49a632ea2310a
+MISC metadata.xml 413 BLAKE2B fc8f119b724d71ff5f53c79db1174ef4d26ab4418ff6ef72dd717f5b4d1211473e88a4bdd421e8aad00606954a4ba80b9d16d7eb14040724f5aba281e97f8a83 SHA512 bbe0abb6afd27760324e085b2a6775c8d4c7199cb82c1d92140498d17462ccea1461fcc830490070c0475ff05e161a2e635027e0bfa53fef0c65da021d353259
diff --git a/media-sound/spotify-tray/metadata.xml b/media-sound/spotify-tray/metadata.xml
new file mode 100644
index 000000000000..5b36c64896b9
--- /dev/null
+++ b/media-sound/spotify-tray/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tsmetana/spotify-tray</remote-id>
+ <bugs-to>https://github.com/tsmetana/spotify-tray/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/spotify-tray/spotify-tray-1.3.1.ebuild b/media-sound/spotify-tray/spotify-tray-1.3.1.ebuild
new file mode 100644
index 000000000000..28d534d9a35d
--- /dev/null
+++ b/media-sound/spotify-tray/spotify-tray-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg
+
+DESCRIPTION="Wrapper around the Spotify client that adds a tray icon"
+HOMEPAGE="https://github.com/tsmetana/spotify-tray"
+SRC_URI="https://github.com/tsmetana/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ x11-libs/gtk+:3[X]
+"
+RDEPEND="${DEPEND}
+ media-sound/spotify
+"
+
+src_prepare() {
+ default
+ # Fix the name of the icon
+ sed -i -e 's/Icon=spotify/Icon=spotify-client/g' spotify-tray.desktop.in || die
+ eautoreconf
+}