summaryrefslogtreecommitdiff
path: root/media-sound/lilypond/lilypond-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-17 14:32:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-17 14:32:10 +0100
commit51c50bd4c895ebf56d81fecae8e45ec3b5fc3efa (patch)
tree753b6b08624c34d1ed8414bbe22c45409f7741b9 /media-sound/lilypond/lilypond-9999.ebuild
parentbe9d77d3ac6af8f4ead98d89706f356b65578c93 (diff)
parentdeba8115d2c2af26df42966b91ef04ff4dd79cde (diff)
Merge branch 'edge' into next
Diffstat (limited to 'media-sound/lilypond/lilypond-9999.ebuild')
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild48
1 files changed, 25 insertions, 23 deletions
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index 545b867b9356..6d4c51473a1f 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -2,15 +2,16 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
PYTHON_COMPAT=( python3_{6,7,8} )
+
inherit elisp-common autotools python-single-r1 toolchain-funcs xdg-utils
if [[ "${PV}" = "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.savannah.gnu.org/git/lilypond.git"
else
- SRC_URI="http://lilypond.org/download/sources/v$(ver_cut 1-2)/${P}.tar.gz"
+ MAIN_VER=$(ver_cut 1-2)
+ SRC_URI="http://lilypond.org/download/sources/v${MAIN_VER}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
fi
@@ -19,41 +20,45 @@ HOMEPAGE="http://lilypond.org/"
LICENSE="GPL-3 FDL-1.3"
SLOT="0"
-IUSE="debug emacs profile vim-syntax"
+IUSE="debug emacs guile2 profile vim-syntax"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
- >=app-text/ghostscript-gpl-8.15
- >=dev-scheme/guile-2:12[deprecated,regex]
+BDEPEND="
+ >=dev-texlive/texlive-metapost-2013
+ || (
+ >=app-text/texlive-core-2013
+ >=dev-tex/metapost-1.803
+ )
+ >=sys-apps/texinfo-4.11
+ >=sys-devel/bison-2.0
+ sys-devel/flex
+ virtual/pkgconfig
+"
+RDEPEND=">=app-text/ghostscript-gpl-8.15
+ >=dev-scheme/guile-1.8.2:12=[deprecated,regex]
media-fonts/tex-gyre
media-libs/fontconfig
media-libs/freetype:2
>=x11-libs/pango-1.12.3
emacs? ( >=app-editors/emacs-23.1:* )
-"
+ guile2? ( >=dev-scheme/guile-2:12 )
+ !guile2? (
+ >=dev-scheme/guile-1.8.2:12=[deprecated,regex]
+ <dev-scheme/guile-2.0:12
+ )
+ ${PYTHON_DEPS}"
DEPEND="${RDEPEND}
app-text/t1utils
dev-lang/perl
dev-libs/kpathsea
- >=dev-texlive/texlive-metapost-2013
- || (
- >=app-text/texlive-core-2013
- >=dev-tex/metapost-1.803
- )
- virtual/pkgconfig
media-gfx/fontforge[png]
- >=sys-apps/texinfo-4.11
- >=sys-devel/bison-2.0
- sys-devel/flex
- sys-devel/gettext
- sys-devel/make
-"
+ sys-devel/gettext"
# Correct output data for tests isn't bundled with releases
RESTRICT="test"
PATCHES=(
- "${FILESDIR}"/${PN}-2.19.80-fontforge-version.patch
+ "${FILESDIR}"/${PN}-2.21.1-fix-font-size.patch
)
DOCS=( DEDICATION HACKING README.txt ROADMAP )
@@ -80,9 +85,6 @@ src_prepare() {
# respect CFLAGS
sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
- # respect AR
- sed -i "s:^AR=ar:AR=$(tc-getAR):" flower/GNUmakefile || die
-
# remove bundled texinfo file (fixes bug #448560)
rm tex/texinfo.tex || die