summaryrefslogtreecommitdiff
path: root/media-sound/exaile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /media-sound/exaile
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'media-sound/exaile')
-rw-r--r--media-sound/exaile/Manifest4
-rw-r--r--media-sound/exaile/exaile-4.0.0_rc3.ebuild79
-rw-r--r--media-sound/exaile/metadata.xml3
3 files changed, 85 insertions, 1 deletions
diff --git a/media-sound/exaile/Manifest b/media-sound/exaile/Manifest
index 96193b115a5b..7c250031958c 100644
--- a/media-sound/exaile/Manifest
+++ b/media-sound/exaile/Manifest
@@ -1,3 +1,5 @@
DIST exaile-3.4.5.tar.gz 3662446 BLAKE2B 13343a5468a4f7f309e173e5195d356d62e10efc20c99cc70a1f0215fafa073eeec19b4e35ae52e11a62575a72263ad11ebdf105fcdd066654f8d6c2b1ff6864 SHA512 9337b86ed2f6a13071615bd46a7a05a6564011a4e1fef4cb42925336864c07854cfe497d8defe65c4e287fd9546de6a51543180c5ce6a84525506e57209914be
+DIST exaile-4.0.0rc3.tar.gz 3627782 BLAKE2B 1c986309798d4cb78969a7443e4c29e02ca3a9c8e316264641ffafe97dd46b6a1745988230c13469ce2d9c37aadf7b07eee5bcd5836f33b1b2d25e3ebb69f574 SHA512 d3822a7d88934c90a2856074f177a346b19896ecca54f33e7506d37a0b25170983c057feaae162c2685780e7f0d1a6edc8ce7addbcc04cacf2d2b25e0c9f36de
EBUILD exaile-3.4.5.ebuild 1273 BLAKE2B 8b3c72922d2831f2986a29e2564cc918457087f853aed9c6d062d6053064f13ca0cad51243b2f9a7b1f4a43888f8d42a6ec503d261c175c19bca4b16f31a550a SHA512 f7bf1db46bde640508dc3efa6cafc6cdedffca9b11aa9bcecdd9aeaaf5f87285966f287416a534d4def09d137bc3a89f38b35882143bf692bd80f93688fa4f73
-MISC metadata.xml 380 BLAKE2B 9d0cff24c31104dac5ff1d9911df1bc67c25f6765b723591ae1a0849f539c44469d10956105dddefdb377375a01099331eb0b223627fbcb3459c6994b4db2507 SHA512 763f538de48767038faac1b7ffed4ac1422be573b6e2e01ff6679e8aeff00f2d14a3fc6bcf40e742a639f36f13cfe893fea77e5fd4f8a273af5d8cfa8db529bf
+EBUILD exaile-4.0.0_rc3.ebuild 1864 BLAKE2B 23fbc21fb61f762cfb3c1dd7f1d3d1addfaf81e25b8714e2f76ef1784e5830931c69fb646fb59581b983b0a461811ffaf0d108c35f119044022826fa96a9f497 SHA512 e9f9062e921f0a29b974506f31b6179cce857f9966aa8d9c86bce2ce4ef9d3bd7a5c954477ba1a8dd69892c278ef20ef622da785ac5d73103e9a0bc8190fb82e
+MISC metadata.xml 465 BLAKE2B 1524388af85ca2f4b928ad4670fa8cc2a86a69f51d72c0dc0a755ca22a05ec95587bab11cfa9f10c9f65cd9a4b08c91ec1fb445f69f9163f54b4a86e2fb99746 SHA512 4185b5a40189086940aa0139e953f39d0af627af73ef2c34f77727e7b8ce596f6f69350531cc7b85cbea4968b7b4413f923f9eda61738a8e1c1dee3b85809942
diff --git a/media-sound/exaile/exaile-4.0.0_rc3.ebuild b/media-sound/exaile/exaile-4.0.0_rc3.ebuild
new file mode 100644
index 000000000000..f3e1373fd4ab
--- /dev/null
+++ b/media-sound/exaile/exaile-4.0.0_rc3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+inherit python-single-r1 xdg-utils
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/exaile/exaile.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV/_/-}/${PN}-${PV/_/}.tar.gz"
+ KEYWORDS="~amd64 ~sparc ~x86"
+ S="${WORKDIR}/${PN}-${PV/_/}"
+fi
+
+DESCRIPTION="GTK+ based media player aiming to be similar to Amarok"
+HOMEPAGE="https://www.exaile.org/"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+IUSE="cddb libnotify nls scrobbler"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/gobject-introspection[${PYTHON_USEDEP}]
+ dev-python/bsddb3[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.13.2:3[${PYTHON_USEDEP}]
+ >=media-libs/gst-plugins-base-1.6:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+ >=media-libs/mutagen-1.10[${PYTHON_USEDEP}]
+ media-plugins/gst-plugins-meta:1.0
+ >=x11-libs/gtk+-3.10:3[introspection]
+ cddb? ( dev-python/cddb-py )
+ libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
+ scrobbler? ( dev-python/pylast[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+
+RESTRICT="test" #315589
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_compile() {
+ use nls && emake locale
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/usr/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale)
+
+ python_optimize "${D}/usr/$(get_libdir)/${PN}"
+ python_optimize "${D}/usr/share/${PN}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
diff --git a/media-sound/exaile/metadata.xml b/media-sound/exaile/metadata.xml
index 3f99551b683a..56d330882f09 100644
--- a/media-sound/exaile/metadata.xml
+++ b/media-sound/exaile/metadata.xml
@@ -9,4 +9,7 @@
<remote-id type="launchpad">exaile</remote-id>
<remote-id type="github">exaile/exaile</remote-id>
</upstream>
+ <use>
+ <flag name="scrobbler">Enable audioscrobbler/last.fm support</flag>
+ </use>
</pkgmetadata>