summaryrefslogtreecommitdiff
path: root/media-libs/gegl/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /media-libs/gegl/files
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'media-libs/gegl/files')
-rw-r--r--media-libs/gegl/files/gegl-0.3.34-failing-tests.patch27
-rw-r--r--media-libs/gegl/files/gegl-0.3.34-fno-common.patch11
2 files changed, 38 insertions, 0 deletions
diff --git a/media-libs/gegl/files/gegl-0.3.34-failing-tests.patch b/media-libs/gegl/files/gegl-0.3.34-failing-tests.patch
new file mode 100644
index 000000000000..c388ac556e9b
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.3.34-failing-tests.patch
@@ -0,0 +1,27 @@
+diff -Naur a/tests/ff-load-save/Makefile.am b/tests/ff-load-save/Makefile.am
+--- a/tests/ff-load-save/Makefile.am 2017-09-21 22:11:00.000000000 +0300
++++ b/tests/ff-load-save/Makefile.am 2020-03-07 16:33:21.000000000 +0300
+@@ -6,13 +6,7 @@
+
+ EXTRA_DIST = $(TESTS)
+
+-check: vids images
+-
+-images:
+- for a in *.avi *.mp4 *.ogv ;do \
+- GEGL_PATH=$(top_builddir)/operations $(top_builddir)/examples/gegl-video \
+- $$a -s 74 -e 74 -of $$a- ;\
+- done
++check: vids
+
+ vids: $(TESTS) $(top_builddir)/examples/frame-counter
+ GEGL_PATH=$(top_builddir)/operations $(top_builddir)/examples/frame-counter \
+@@ -27,8 +21,6 @@
+ --video-codec mpeg4 --fps 12 --video-bit-rate 128 128kb-12fps.mp4
+ GEGL_PATH=$(top_builddir)/operations $(top_builddir)/examples/frame-counter \
+ --video-codec mpeg4 --fps 100 --video-bit-rate 128 128kb-100fps.mp4
+- GEGL_PATH=$(top_builddir)/operations $(top_builddir)/examples/frame-counter \
+- --fps 28 --video-bit-rate 512 512kb-28fps.ogv
+
+ clean-local:
+ rm -f *.png *.avi *.ogv *.mp4 *.webm
diff --git a/media-libs/gegl/files/gegl-0.3.34-fno-common.patch b/media-libs/gegl/files/gegl-0.3.34-fno-common.patch
new file mode 100644
index 000000000000..8c1c045758b4
--- /dev/null
+++ b/media-libs/gegl/files/gegl-0.3.34-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/gcut/gcut.h
++++ b/gcut/gcut.h
+@@ -172,7 +172,7 @@
+ GMutex mutex;
+ };
+
+-struct _GeglEDL
++extern struct _GeglEDL
+ {
+ GFileMonitor *monitor;
+ char *path;