summaryrefslogtreecommitdiff
path: root/games-strategy/ja2-stracciatella-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-strategy/ja2-stracciatella-data
reinit the tree, so we can have metadata
Diffstat (limited to 'games-strategy/ja2-stracciatella-data')
-rw-r--r--games-strategy/ja2-stracciatella-data/Manifest4
-rw-r--r--games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild57
-rw-r--r--games-strategy/ja2-stracciatella-data/metadata.xml8
3 files changed, 69 insertions, 0 deletions
diff --git a/games-strategy/ja2-stracciatella-data/Manifest b/games-strategy/ja2-stracciatella-data/Manifest
new file mode 100644
index 000000000000..1f064d204aea
--- /dev/null
+++ b/games-strategy/ja2-stracciatella-data/Manifest
@@ -0,0 +1,4 @@
+EBUILD ja2-stracciatella-data-1.ebuild 1311 SHA256 8d8924e0e377a829870b4f42fad761a773c0a7125668f0d1896dda44f11bbdcb SHA512 f7802c8c2464f450a5ad231bece88dd8119b619991bf9aba6087f856f6811f4290a1df80997fcab9eb22ca78f825c3e90b42d5fffc0adab0f9132c5edd167dbb WHIRLPOOL 08f60b4746b05174abef8aa8b2867734acc18247ff0fb97e3b99460668f2ffa473666d06bc4daeca841282abd48f93902beb760b9972aa267a75fbded83ba07b
+MISC ChangeLog 3020 SHA256 36a102a9ec86f0bf6d965ac3a7d8fc1a92df30a72b0c6184b2e0abd670bef9e1 SHA512 b40cbc8e105b6d2c229c1357a454d3cc65f9a50757e7a02534fbf201876d1d8775948617f54af1cf2bcf0356f5046901e012f5229ccea76a12f836d4a54fb6b5 WHIRLPOOL 69eec4a95166f2fc93e820e7d9f0c1018c3c0840de0ccc0eb0df5429093bab80520189da1803e1571d1d96a3c22c1c8bd54a2b8a3fe766d0c2ea2ab4824028df
+MISC ChangeLog-2015 859 SHA256 a70082131e7aec5950441011f7750ee56b2fcc6499694c37f4996cc08447af71 SHA512 b3fb8c59fe62acadfb1d61978b15d230a94833a9dae9ea3de47e249ae32bc22c64637605bf7339a5b9a97c75e09c0ca603fee97e29711ae732454c5b10464ea1 WHIRLPOOL a53d0968c11d14b4dbe9bc40af8a2bf3f6780a1da0bc61e81f3011913e291358b6cf961b229eba12bdba2c35ed6f935145360d080497765a6b131a243c5c43e1
+MISC metadata.xml 253 SHA256 2c95b2eb99144a3b66de17be35eebcf65e5a152a2ec2f176165bb9cd78e5394e SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254 WHIRLPOOL fd044f0a960e57257f4a15ab16f066bbfe9983e60cd5fc072e631efc7027306c612a01d7fbbf57eb08d957487a7ce1961250194653d6ed87ee23f20d631ef854
diff --git a/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild b/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild
new file mode 100644
index 000000000000..2be69ceaae8d
--- /dev/null
+++ b/games-strategy/ja2-stracciatella-data/ja2-stracciatella-data-1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cdrom check-reqs games
+
+DESCRIPTION="A port of Jagged Alliance 2 to SDL (data files)"
+HOMEPAGE="http://tron.homeunix.org/ja2/"
+SRC_URI=""
+
+LICENSE="SIR-TECH"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unshield"
+
+S=${WORKDIR}
+
+CHECKREQS_DISK_BUILD="3G"
+CHECKREQS_DISK_USR="1G"
+
+src_unpack() {
+ export CDROM_NAME="INSTALL_CD"
+
+ cdrom_get_cds INSTALL/data1.cab
+
+ # this makes some serious overhead
+ unshield x "${CDROM_ROOT}"/INSTALL/data1.cab || die "unpacking failed"
+}
+
+src_prepare() {
+ cd "${S}"/Ja2_Files/Data || die
+ local lower i
+
+ # convert to lowercase
+ find . \( -iname "*.jsd" -o -iname "*.wav" -o -iname "*.sti" -o -iname "*.slf" \) \
+ -exec sh -c 'echo "${1}"
+ lower="`echo "${1}" | tr [:upper:] [:lower:]`"
+ [ -d `dirname "${lower}"` ] || mkdir `dirname ${lower}`
+ [ "${1}" = "${lower}" ] || mv "${1}" "${lower}"' - {} \;
+
+ # remove possible leftover
+ rm -r ./TILECACHE ./STSOUNDS
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/ja2/data
+ doins -r "${S}"/Ja2_Files/Data/*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "This is just the data portion of the game. You will need to install"
+ elog "games-strategy/ja2-stracciatella to play the game."
+}
diff --git a/games-strategy/ja2-stracciatella-data/metadata.xml b/games-strategy/ja2-stracciatella-data/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/games-strategy/ja2-stracciatella-data/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>