summaryrefslogtreecommitdiff
path: root/games-action/shadowgrounds-survivor-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-action/shadowgrounds-survivor-bin
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-action/shadowgrounds-survivor-bin')
-rw-r--r--games-action/shadowgrounds-survivor-bin/Manifest2
-rw-r--r--games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1-r1.ebuild (renamed from games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1.ebuild)32
2 files changed, 17 insertions, 17 deletions
diff --git a/games-action/shadowgrounds-survivor-bin/Manifest b/games-action/shadowgrounds-survivor-bin/Manifest
index 5a6e589a4c8a..02bd95e04b02 100644
--- a/games-action/shadowgrounds-survivor-bin/Manifest
+++ b/games-action/shadowgrounds-survivor-bin/Manifest
@@ -1,3 +1,3 @@
DIST survivorUpdate1.run 1157907155 BLAKE2B a3c4b8ffc6ae6fd1c0537feea635326736b3316db6ee9daf2ef0f8883410cf80580dc0326455b36d0dfabb79792cce793f5ac0dd93645333285af9c0307cdfd1 SHA512 59c911382d120b0b45dd8dc21f5fdeb78b59155514a422c587fba9970a73b46238b170e3e80810e0fc5a6b5dedbb069ec3d2e2a552657eb5bfc101736a0afc36
-EBUILD shadowgrounds-survivor-bin-0_p1.ebuild 1490 BLAKE2B 942752a4b56363557cb3c44344ddece68fe3c2e1f57bbb064c5d9d3107bdc9f72cee281437bc4e638ccdf505a70d8e548c8b0110398e5fa71503c96cc978fb10 SHA512 6f6b70cf595d3ca9b9703648443e903c437502a486c703b48aa1343cae399b76daa55589c1d2cbcf1207ca5ea11e9c7dc6c0808d56b9d1ac8205afc68df955a3
+EBUILD shadowgrounds-survivor-bin-0_p1-r1.ebuild 1430 BLAKE2B 71e14f22799ecb7e09b4d9e6331dcd506b0a3216bb3bab6e9ee715f4b86a1d909b1eb3874281d15bba6ccddf24e19772bdf19893eb548de61c3d9e94f00f8bda SHA512 9617803bdee9e8e82f044d5fbe91441d84abb37b1535b8002dfe529d400590afc4aa39152e449155ee506e053b92bc38b4e8ca0229f088547e35293c014befc1
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1.ebuild b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1-r1.ebuild
index 242be142fe41..09beed77b703 100644
--- a/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1.ebuild
+++ b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_p1-r1.ebuild
@@ -1,34 +1,35 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit unpacker eutils games versionator
+EAPI=7
-DIST_PV=$(get_version_component_range 2)
+inherit desktop unpacker wrapper
+
+DIST_PV=$(ver_cut 2-)
DESCRIPTION="human survivors who battle against the ongoing alien onslaught"
HOMEPAGE="http://shadowgroundsgame.com/survivor/"
SRC_URI="survivorUpdate${DIST_PV/p/}.run"
+S="${WORKDIR}"
LICENSE="frozenbyte-eula"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
RESTRICT="fetch strip"
-DEPEND="app-arch/unzip"
-RDEPEND=">=sys-libs/glibc-2.4
+RDEPEND="
>=sys-devel/gcc-4.3.0
+ >=sys-libs/glibc-2.4
!amd64? (
gnome-base/libglade
)
amd64? (
>=gnome-base/libglade-2.6.4-r1[abi_x86_32(-)]
- )"
-
-S=${WORKDIR}
+ )
+"
+BDEPEND="app-arch/unzip"
-d="${GAMES_PREFIX_OPT}/${PN}"
+d="opt/${PN}"
QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
QA_TEXTRELS_amd64=${QA_TEXTRELS_x86}
@@ -38,9 +39,9 @@ pkg_nofetch() {
}
src_unpack() {
- # manually run unzip as the initial seek causes it to exit(1)
+ # Manually run unzip as the initial seek causes it to exit(1)
unpack_zip ${A}
- rm lib*/lib{gcc_s,m,rt,selinux}.so.?
+ rm lib*/lib{gcc_s,m,rt,selinux}.so.? || die
}
src_install() {
@@ -51,7 +52,8 @@ src_install() {
bb="survivor-${b}"
exeinto ${d}
newexe ${bb} ${bb}
- games_make_wrapper ${bb} "./${bb}" "${d}"
+
+ make_wrapper ${bb} "./${bb}" "${d}"
make_desktop_entry ${bb} "Shadowgrounds Survivor ${b}" "Shadowgrounds Survivor"
done
@@ -60,6 +62,4 @@ src_install() {
insinto ${d}
doins -r Config data Profiles *.fbz *.glade *-logo.png
-
- prepgamesdirs
}