summaryrefslogtreecommitdiff
path: root/dev-vcs/git-imerge/git-imerge-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-vcs/git-imerge/git-imerge-1.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/git-imerge/git-imerge-1.0.0.ebuild')
-rw-r--r--dev-vcs/git-imerge/git-imerge-1.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-vcs/git-imerge/git-imerge-1.0.0.ebuild b/dev-vcs/git-imerge/git-imerge-1.0.0.ebuild
new file mode 100644
index 000000000000..249da409f76c
--- /dev/null
+++ b/dev-vcs/git-imerge/git-imerge-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Incremental merge for git"
+HOMEPAGE="https://github.com/mhagger/git-imerge"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-vcs/git"
+DEPEND="dev-python/docutils"
+
+src_compile() {
+ for doc in *.rst; do
+ rst2html.py "${doc}" > "${T}/${doc/.rst/.html}" \
+ || die "failed to convert ${doc} to ${T}/${doc/.rst/.html}"
+ done
+
+ rst2s5.py \
+ --theme=small-white \
+ --current-slide \
+ doc/presentations/GitMerge-2013/talk.rst \
+ "${T}/talk.html" \
+ || die 'failed to convert talk.rst to ${T}/talk.html'
+}
+
+src_install() {
+ python_foreach_impl python_doscript "${PN}"
+ newbashcomp "${FILESDIR}/git-imerge.bashcomplete" git-imerge
+ dodoc *.rst "${T}"/*.html
+
+ # Don't forget the CSS for the presentation.
+ dodoc -r "${T}/ui"
+}