summaryrefslogtreecommitdiff
path: root/dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild')
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild
deleted file mode 100644
index bfdeb720bee4..000000000000
--- a/dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_SINGLE_IMPL=1
-
-inherit distutils-r1
-
-FILEVER="49237"
-
-DESCRIPTION="Convert a CVS repository to a Subversion repository"
-HOMEPAGE="http://cvs2svn.tigris.org/"
-SRC_URI="http://cvs2svn.tigris.org/files/documents/1462/${FILEVER}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="bazaar git test"
-
-DEPEND=">=dev-vcs/subversion-1.0.9"
-RDEPEND="${DEPEND}
- bazaar? ( >=dev-vcs/bzr-1.13[${PYTHON_USEDEP}] )
- git? ( >=dev-vcs/git-1.5.4.4[${PYTHON_USEDEP}] )
- dev-vcs/rcs"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- distutils-r1_src_prepare
- python_fix_shebang .
-}
-
-src_compile() {
- distutils-r1_src_compile
- emake man
-}
-
-src_install() {
- distutils-r1_src_install
- insinto "/usr/share/${PN}"
- doins -r contrib cvs2{svn,git,bzr}-example.options
- doman *.1
-}
-
-python_test() {
- # Need this because subversion is localized, but the tests aren't
- export LC_ALL=C
- "${PYTHON}" -W ignore run-tests.py
-}
-
-pkg_postinst() {
- elog "Additional scripts and examples have been installed to:"
- elog " /usr/share/${PN}/"
-}