summaryrefslogtreecommitdiff
path: root/dev-ruby/typeprof
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /dev-ruby/typeprof
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'dev-ruby/typeprof')
-rw-r--r--dev-ruby/typeprof/Manifest3
-rw-r--r--dev-ruby/typeprof/metadata.xml11
-rw-r--r--dev-ruby/typeprof/typeprof-0.11.0.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/typeprof/Manifest b/dev-ruby/typeprof/Manifest
new file mode 100644
index 000000000000..54cc9edc5fbb
--- /dev/null
+++ b/dev-ruby/typeprof/Manifest
@@ -0,0 +1,3 @@
+DIST typeprof-0.11.0.tar.gz 496673 BLAKE2B 215bd738a4a4b9e7de78943a944fd63dd4f166f215a493cdc89270e0452453683d3fdd1f71ccc05f4399f61e120248a73ed9b77b5b24ed4aa8b54e97d9e0073d SHA512 cc64bd805c57a16c275ba5622df08ff30fd64ae82b18e29fb30e03d17a6ca0e889c03696c745597bfec6444290f1f33020c4bd9c49a02fc3053add33e3e60084
+EBUILD typeprof-0.11.0.ebuild 950 BLAKE2B 34b26b92c34cb16712bdf7245e137addae635b903348b7ae10e9f4f3ed6d14c95ba0bc641e76eae9d97583888e26d8a143df48337bed08121839625366cd1c17 SHA512 556c2bbaf1bba98b93ef39aeff517aa758629fc1420d10ebf35c37d2c8d2206b4e1e7788d560b5b7e6bcc37a70af691a44200159de9e70b7d3acdb841b54e4d3
+MISC metadata.xml 339 BLAKE2B ca2bb0c0a59ddafbf4c57b268985a52e02a15089f6784cab9dfa3aa6645275c51df7a95288d2464e357a2a1f9a53735e9e9fdc13195a7383eba5d821d89baa2a SHA512 79d803bea464c53a176d07b5bb9bba5d434b1f24a97e8091fd85fb36a842abe93cb0adf82ccbdbd1ef7adafab3210f4bcf80a79c99b0a792869360f7e47e6b70
diff --git a/dev-ruby/typeprof/metadata.xml b/dev-ruby/typeprof/metadata.xml
new file mode 100644
index 000000000000..f44cfa2e5512
--- /dev/null
+++ b/dev-ruby/typeprof/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/typeprof</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/typeprof/typeprof-0.11.0.ebuild b/dev-ruby/typeprof/typeprof-0.11.0.ebuild
new file mode 100644
index 000000000000..6dcae41638d8
--- /dev/null
+++ b/dev-ruby/typeprof/typeprof-0.11.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_GEMSPEC="typeprof.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Performs a type analysis of non-annotated Ruby code"
+HOMEPAGE="https://github.com/ruby/typeprof"
+SRC_URI="https://github.com/ruby/typeprof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/rbs-1.0.0"
+
+all_ruby_prepare() {
+ # Avoid tests that download live code using git
+ rm -r test/typeprof/{goodcheck,diff-lcs}_test.rb || die
+
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+}