summaryrefslogtreecommitdiff
path: root/dev-ruby/mini_magick/mini_magick-4.5.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/mini_magick/mini_magick-4.5.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/mini_magick/mini_magick-4.5.1-r1.ebuild')
-rw-r--r--dev-ruby/mini_magick/mini_magick-4.5.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/mini_magick/mini_magick-4.5.1-r1.ebuild b/dev-ruby/mini_magick/mini_magick-4.5.1-r1.ebuild
new file mode 100644
index 000000000000..6990bdc73cd3
--- /dev/null
+++ b/dev-ruby/mini_magick/mini_magick-4.5.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Manipulate images with minimal use of memory"
+HOMEPAGE="https://github.com/minimagick/minimagick"
+SRC_URI="https://github.com/minimagick/minimagick/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="minimagick-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It's only used at runtime in this case because this extension only
+# _calls_ the commands. But when we run tests we're going to need tiff
+# and jpeg support at a minimum.
+RDEPEND+=" media-gfx/imagemagick"
+DEPEND+=" test? ( virtual/imagemagick-tools[jpeg,png,tiff] )"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha dev-ruby/posix-spawn )"
+
+all_ruby_prepare() {
+ # remove executable bit from all files
+ find "${S}" -type f -exec chmod -x {} +
+
+ sed -i -e '/\([Bb]undler\|pry\)/ s:^:#:' spec/spec_helper.rb || die
+
+ # Don't force a specific formatter but use overall Gentoo defaults.
+ sed -i -e '/config.formatter/d' spec/spec_helper.rb || die
+
+ # Avoid broken spec that does not assume . in path name
+ sed -i -e '/reformats a layer/,/end/ s:^:#:' spec/lib/mini_magick/image_spec.rb || die
+}