summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-25 05:40:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-25 05:40:31 +0000
commitd117dce29795dfc5a9824d31a128decaa37f73d2 (patch)
treeef95e8fa6dfdf9a769d594a457e755c8782a345b /dev-python
parentfa49bc1447d334c70e45ded349d3c37319dab7b4 (diff)
gentoo auto-resync : 25:02:2024 - 05:40:31
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin269344 -> 269357 bytes
-rw-r--r--dev-python/bottleneck/Manifest2
-rw-r--r--dev-python/bottleneck/bottleneck-1.3.8.ebuild43
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.98.11.ebuild90
-rw-r--r--dev-python/mkdocs-material/Manifest2
-rw-r--r--dev-python/mkdocs-material/mkdocs-material-9.5.11.ebuild67
-rw-r--r--dev-python/pytest-httpserver/Manifest2
-rw-r--r--dev-python/pytest-httpserver/pytest-httpserver-1.0.10.ebuild39
-rw-r--r--dev-python/pytest/Manifest2
-rw-r--r--dev-python/pytest/pytest-8.0.2.ebuild111
-rw-r--r--dev-python/rq/Manifest2
-rw-r--r--dev-python/rq/rq-1.16.0.ebuild57
13 files changed, 419 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 3816c01ea62c..f3b237114d68 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/bottleneck/Manifest b/dev-python/bottleneck/Manifest
index 58a8efc5c653..1ab007270a83 100644
--- a/dev-python/bottleneck/Manifest
+++ b/dev-python/bottleneck/Manifest
@@ -1,3 +1,5 @@
DIST Bottleneck-1.3.7.tar.gz 103067 BLAKE2B d260263fc05b6806203c09555157926f288c60ebb88105b9ad73191c220be0e08370d7a96cb829ec8dd9ac0c2d243aeca62eb1a871e39fe8c85ba6ab507849ac SHA512 ffeacb13e5a99db85e1580b9f2ead98239b4fd0b253a3c242a5507a026b439b9927ea49becec7e4d2d8f8e4ced15f43514c0af99379389db141ae50c4513e011
+DIST Bottleneck-1.3.8.tar.gz 103252 BLAKE2B 1e520e33eaa86b7328d469a8de2f0cacedb401f9dab3686cad40132caa23e77055b71e630fadda9305f3d416e8958e9762053e6d46afba4cf15489db77418b67 SHA512 951a927ce368643e2ccb5154c05381ce9ff17bc703c0bcd85eab547e345601ad82eb1dc85fa16d667753bf3dc9d0296025984dae463a0153944a85a085331a8e
EBUILD bottleneck-1.3.7.ebuild 906 BLAKE2B 6cfbd51aa3e5b82f5082f636b8edf13d432d5a4533a7d08d4a1e6008b0b753157f2353011003d19c125e23bf1362968320dc4537446d6e70ab416c237234ff73 SHA512 9dbf90172dca4c3f1168fedc1565ca8d39090756ab0c42270f819da5216c3302559ae2b6863dc6c03c956989a6cc43ac5dac2ac5120dbb3a353232867fae2031
+EBUILD bottleneck-1.3.8.ebuild 912 BLAKE2B ec1eeac4647ea8f6c0db3db7d9b96140053f0b25b3db7a8b7d05dc64fea58a1dc6959bbbc25d02ffebfaea8e3c311b9892ccd70d2ed7db7488fb9a7a16d5a83f SHA512 233c73464d0527e9b80fdd9d1594080b900247570d9557b401c694c69f2c3ed98e85aac9eed52a1a2b39e3f2e0dde657ea6e3f0808e65dc6fc7b5bd5ef1d6054
MISC metadata.xml 519 BLAKE2B 5e5e712122fb0bbc898942cbae15c7cf623aa8462257f063f65a06bc9caae6662c373963f0945f99c5fffe01270e2792e8e5d01af93b49a04f5c3c22cd3a30f7 SHA512 55d2c03dedaa48c8f802d1e4d1d7db4e829fe7357b501c3b2955d28da501eae00675b2775ab36d1131cf2ef0a3d037183bde8df4c85e986d81510df4e234b0ae
diff --git a/dev-python/bottleneck/bottleneck-1.3.8.ebuild b/dev-python/bottleneck/bottleneck-1.3.8.ebuild
new file mode 100644
index 000000000000..6e3c7e7eeebb
--- /dev/null
+++ b/dev-python/bottleneck/bottleneck-1.3.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast NumPy array functions written in C"
+HOMEPAGE="
+ https://github.com/pydata/bottleneck/
+ https://pypi.org/project/Bottleneck/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/numpy-1.9.1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # don't overwrites user's optimization level
+ sed -e '/extra_compile_args=\["-O2"\]/d' -i setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ rm -rf bottleneck || die
+ epytest --pyargs bottleneck
+}
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 49d130de2916..55d98c0a3b55 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,7 +1,9 @@
DIST hypothesis-6.97.5.gh.tar.gz 9426065 BLAKE2B 2aec769268af7392f71c0ec7d12defad4962bd56597cb68ca0edfa81dbf28ef7d865b26086b75ee03287c82a0b2c0273a55bd6872b188728595fe74198130dd6 SHA512 d9f2adc51ef3b7fc331d3dca1b69a9464a2bc73298747f3732b8b4621237284ac60a50b927b57a047a155e0d94a3ee2974bbef2c9cf9112080e9098fba3cfc7f
DIST hypothesis-6.98.10.gh.tar.gz 9428083 BLAKE2B 7b1f49fb296097d00396bdcb699203a92ac210d4c05927e5f44cf4d3ab1aadb75a1a13a66bdcd63a582b19b99980e3075b3d481b9d4d8b737e53f410e3821718 SHA512 5cff0fb16e64b9190da4055487945060b0a85c3dbde949bcd9e1931e3825d8316bd3780a432503fce33cab48f078f83d418e4e1760a084a933f591183b22f0c3
+DIST hypothesis-6.98.11.gh.tar.gz 9428472 BLAKE2B 79c4561ac1ac3ad309bccd215bb0b4f1a010b50058e70770ca51cb5e35e5c99e95aaa1d0a757a84fc1c34c117c6d400d40d41ea0dcfc236db2b2bc78812a9671 SHA512 3abe0801e33836727a48bdf7888bfaf0fbe2eca36aa511cdeaed29d45351c250c8f5aed6f47396f1e97fbccbecb45bd0b55b86a2956fa0bd735b99edc6bbe53f
DIST hypothesis-6.98.9.gh.tar.gz 9427046 BLAKE2B c3705e4c780b6e7f427943231ac056f343e70569e88391f118383e6d6197f72e744306476f2e1994e8a6d95dce73b93dcd49e8fa197149e532b84c91bce79594 SHA512 1e8a0dcefb8def8376a0ad6549a58dac66470941e4a3584ba82867f8779fd941c141039f631f15f134f7cdb3beb2ad1a19312d8e56c47db9ace0569f203afaf3
EBUILD hypothesis-6.97.5.ebuild 2461 BLAKE2B 343d4374955bed436ecb2533684eac1d2013c8b6c691bf72477a24c52e5caf7e71e61b67de8475c38e940a13b046ed07e8f2b188ad39c3acff8de4df3f7f5a97 SHA512 3a72f5c9f5c1b3787c37cd8830321a47a5c54c655c8b75fdeaa4b09c6c4db310914ebfa5cf631c2576e92e4bd56e106f745e25777b5f86cd7b0cc58ec838fa7b
EBUILD hypothesis-6.98.10.ebuild 2469 BLAKE2B c411ef0dbd4cb160b7695cd5e9428835163379752bab7b2f4668b7cadff8fb0773ff46540a66c521f15f65cdb4f1f51a832e06adce48491e492a0c4f0dd13499 SHA512 d7031fa1c8a7fe3914019a39976473dbe629b215b40647c262ba8c75a33b668176e5fb3262f01267f81b42b951b641ea561c4f1c2d21f61e4a0f05c5dbfd520c
+EBUILD hypothesis-6.98.11.ebuild 2469 BLAKE2B c411ef0dbd4cb160b7695cd5e9428835163379752bab7b2f4668b7cadff8fb0773ff46540a66c521f15f65cdb4f1f51a832e06adce48491e492a0c4f0dd13499 SHA512 d7031fa1c8a7fe3914019a39976473dbe629b215b40647c262ba8c75a33b668176e5fb3262f01267f81b42b951b641ea561c4f1c2d21f61e4a0f05c5dbfd520c
EBUILD hypothesis-6.98.9.ebuild 2469 BLAKE2B c411ef0dbd4cb160b7695cd5e9428835163379752bab7b2f4668b7cadff8fb0773ff46540a66c521f15f65cdb4f1f51a832e06adce48491e492a0c4f0dd13499 SHA512 d7031fa1c8a7fe3914019a39976473dbe629b215b40647c262ba8c75a33b668176e5fb3262f01267f81b42b951b641ea561c4f1c2d21f61e4a0f05c5dbfd520c
MISC metadata.xml 492 BLAKE2B c9e9bbd59af55d1f47e5b7a86933c02b47f832122d03eaca56bd3ec9476cf260d91d4fd2da5068845d4525b7cc9f702b515e8d6a0dffa7923f5898cfd44e12a1 SHA512 166b33d6ac887f52d54fb9d556102038c00650a597d2de1c3aad3f8b5e136e9b6b7db31f05f3379435e4c5f943156d5839d78fc95461af411037a3162ea6705e
diff --git a/dev-python/hypothesis/hypothesis-6.98.11.ebuild b/dev-python/hypothesis/hypothesis-6.98.11.ebuild
new file mode 100644
index 000000000000..f7f366381e4f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.98.11.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}
diff --git a/dev-python/mkdocs-material/Manifest b/dev-python/mkdocs-material/Manifest
index 7c0f9da62ecf..b32e790b73af 100644
--- a/dev-python/mkdocs-material/Manifest
+++ b/dev-python/mkdocs-material/Manifest
@@ -1,8 +1,10 @@
AUX mkdocs-material-8.5.7-simplify-build.patch 529 BLAKE2B 60a246940983ca713b370b454fff74a36dedf1aec175e72455255b35164f75f7eb79144cff67df4b1ec143a4e19b043042c9bce562456133c917c27018c4862a SHA512 51b18f3faa4a3adfc9cf8ad1fa5fd63f787a3b2b9c9769b5889a2abab621ff6e14e034487f5573418405b26bc11155e44f7c6d50acea8baf9f45164fb3ec7984
DIST mkdocs-material-9.5.10.gh.tar.gz 14770017 BLAKE2B 90f436c205d226332b1b3acee73649a77bf01ced13e403230396f0fcf5aa7a30721d1eacb6b788324f12b08c190c7387677f4588d00d6ccab59b6ed46d2fbc1f SHA512 4ab89fdf3f31355520d49e290db613e8585a92a349bc5bb064363d8dc6c65c2998cceb2e455324880166300b05593e2195c6dcf916dbe5ac286f3112ff4f82a2
+DIST mkdocs-material-9.5.11.gh.tar.gz 14776542 BLAKE2B c15e89522b1720aba4fbd00d9039238be43a96765010ab8a3197e6e964036db5b959595facc6debd2d582740bfcd2134abc8773f767188b45af6e26ce5234400 SHA512 b0c532dd96abc656fb3b3fe45b2c6b90ac29edae35492423f7a62851dbd4c07c6cf32249f09d67e1266293f5afbc6675505260770f3cbfed08d50f07342c17de
DIST mkdocs-material-9.5.7.gh.tar.gz 14715071 BLAKE2B 4eb978e28150b00b925fa151445b459cb048b8a48526aadc1f82b12fab65e8635d1417546b280cfd7af3dc6a9cf4d2ed7984958896bfa910d3d14fa27059c907 SHA512 4a5163bb5e5705a1d9bf35ed88746cff1e8bb74e7dfa92b73304a9261702449e6c63fbbcaf7680ff28ba8a344376adf777d74f145f3668076036518c143064e5
DIST mkdocs-material-9.5.9.gh.tar.gz 14726800 BLAKE2B dad4da1b661b0e1c67884248cf526bc19b3c2e33d5d2da7bfcc5589f6dde953147672ac657e84e7825ef8dcc061f6bc8aaabd6b24a3caa962dbdfa5ab8f2d49e SHA512 74031f4e9bb3ffd5cd02ee4301b5d61861e36a5cbdbc385c7db253e18c4d935ef959bf6c58033887f1edd6e3011d38b45c6bdca0ae838f76536df439447d79fc
EBUILD mkdocs-material-9.5.10.ebuild 1797 BLAKE2B a39f2daf4cb4df3d7b94ba8d4cd5c7ba541e97afbe8747f21ce9f6e88e4455e2b40d13a37090ff0df1d5b98676c73e4c6d1db7a89f09c315034e00c823c39c5f SHA512 482cd4f0c8e3512b8f3270115b1a90f727ab29d9c7097deb9a5a0215516f2b9ac1825f00bf1ae50b91b8aaeb22b75f7b77f1e8e22c10efb4ea8424a2e7a5ce5a
+EBUILD mkdocs-material-9.5.11.ebuild 1797 BLAKE2B a39f2daf4cb4df3d7b94ba8d4cd5c7ba541e97afbe8747f21ce9f6e88e4455e2b40d13a37090ff0df1d5b98676c73e4c6d1db7a89f09c315034e00c823c39c5f SHA512 482cd4f0c8e3512b8f3270115b1a90f727ab29d9c7097deb9a5a0215516f2b9ac1825f00bf1ae50b91b8aaeb22b75f7b77f1e8e22c10efb4ea8424a2e7a5ce5a
EBUILD mkdocs-material-9.5.7.ebuild 1794 BLAKE2B 57edfb330af7a05f23b7baa57c878462f123a83e5b647ecfab1b8e25e5aa44a59586878bab2e3b7744174bc818dd4ba6b4561d3bfb7df69de53db1112ece4545 SHA512 bdb3af90984d501faa16d0cd27bf72fc9e4965ecbf427b99fcb5e7d615f4edb8610bfeb86b958559a3640b05d4bef3e2d7fe35a3e136ef044886461deae6496a
EBUILD mkdocs-material-9.5.9.ebuild 1797 BLAKE2B a39f2daf4cb4df3d7b94ba8d4cd5c7ba541e97afbe8747f21ce9f6e88e4455e2b40d13a37090ff0df1d5b98676c73e4c6d1db7a89f09c315034e00c823c39c5f SHA512 482cd4f0c8e3512b8f3270115b1a90f727ab29d9c7097deb9a5a0215516f2b9ac1825f00bf1ae50b91b8aaeb22b75f7b77f1e8e22c10efb4ea8424a2e7a5ce5a
MISC metadata.xml 1146 BLAKE2B c9eb031eb40f303fdcc39f891cdd2d4317075deb030d0f8374f874ecd63bf73960427eb3ee485b5b28515f58689b1e1bf977ee7b565bf8f9275b115853044f2c SHA512 01db399842cb09af4823278f84fcf8c51ed42609a2e61d8e64964e1759e14d22ed2f32ec0565f19184575089a218dad4939337798cd3a5b39f5be55f5f7edb69
diff --git a/dev-python/mkdocs-material/mkdocs-material-9.5.11.ebuild b/dev-python/mkdocs-material/mkdocs-material-9.5.11.ebuild
new file mode 100644
index 000000000000..46c2a0851fa9
--- /dev/null
+++ b/dev-python/mkdocs-material/mkdocs-material-9.5.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/mkdocs-material-extensions
+ dev-python/mkdocs-minify-plugin
+ dev-python/mkdocs-redirects
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="A Material Design theme for MkDocs"
+HOMEPAGE="
+ https://github.com/squidfunk/mkdocs-material/
+ https://pypi.org/project/mkdocs-material/
+"
+SRC_URI="
+ https://github.com/squidfunk/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="social"
+
+RDEPEND="
+ >=dev-python/Babel-2.10.3[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.2[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.5.3[${PYTHON_USEDEP}]
+ >=dev-python/paginate-0.5.6[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.16[${PYTHON_USEDEP}]
+ >=dev-python/pymdown-extensions-10.2[${PYTHON_USEDEP}]
+ >=dev-python/readtime-2.0[${PYTHON_USEDEP}]
+ >=dev-python/regex-2022.4.24[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26[${PYTHON_USEDEP}]
+ social? (
+ >=dev-python/pillow-10.2[${PYTHON_USEDEP}]
+ >=media-gfx/cairosvg-2.5[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ >=dev-python/trove-classifiers-2023.10.18[${PYTHON_USEDEP}]
+"
+# mkdocs-material-extensions depends on mkdocs-material creating a circular dep
+PDEPEND="
+ >=dev-python/mkdocs-material-extensions-1.2[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ # simplify pyproject to remove extra deps for metadata
+ "${FILESDIR}/${PN}-8.5.7-simplify-build.patch"
+)
+
+src_prepare() {
+ echo "__version__ = '${PV}'" > gentoo_version.py || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/pytest-httpserver/Manifest b/dev-python/pytest-httpserver/Manifest
index 94e420d18370..de78494b9c34 100644
--- a/dev-python/pytest-httpserver/Manifest
+++ b/dev-python/pytest-httpserver/Manifest
@@ -1,5 +1,7 @@
+DIST pytest_httpserver-1.0.10.tar.gz 60446 BLAKE2B 99d1db58f7b6fab78b687db0fc2448cbd9a3132b999e4d0ca1c8533ec2afebc717b9c28a16635260fb305aaafb832f591d28752ba3930473312a677dfaffd0be SHA512 f8636ccf757f687666a5336db66ac061ea6205979c7bbf8c9a2534282d8559453a7470318c07384aa755282c12e63537cce2ab9e9f3b2fbcda0e649ed2a45f92
DIST pytest_httpserver-1.0.8.tar.gz 60126 BLAKE2B 9da65074aeca7de6a91c7afab7ac83ec8724c0595efe4abe7f3e2951ac37137c48a770ea1b5baeeb7484d647c1a03c20c86ad4de7627fb63beef174a2f7c3925 SHA512 5acff56b1c250c190da6466d398c10f206a24fe4112628ba4ec56bb2e23e21408b13d22ab6ad428e7ad7e685d7f2e73d5fc4b7afe86e7cb88d844a6e8e1a6bb4
DIST pytest_httpserver-1.0.9.tar.gz 60048 BLAKE2B 1eeecb67624d7ced713f0901c912a559e9e30c1875933cc799c3e6eca1e39941f8c556e053cc8d4a155e9c29f68d659560b0d6f51e57b97ed850b6d4ae9357ad SHA512 64d9ac47de264b0c151b17a52c904451f59e4035ad87b16a534fcccf7725b82d343736366ee3f5be03947c2f05dfb0a52bb7148014aa1a3d179748a6870e49c7
+EBUILD pytest-httpserver-1.0.10.ebuild 784 BLAKE2B 48f7159e96013b3606b2967793ff66a88cedf24fb5e537696e11e9eb571430bbabc81b7863d9e5bbc62a281e224afec5bb8438e2e1cc59fd008d2a1e3792e4f1 SHA512 642c0c10eda4d2a9cb480dc8a27261031cded33bd2df49595ae8e30232871232ae5ff5d17a5659a40c2154b65952c59dde0c1d7f9a68fa57d050d037bf76526a
EBUILD pytest-httpserver-1.0.8.ebuild 776 BLAKE2B e23c2adcb2bc29a7cab0e7337cad1e1f7d508d0ab288304751db4dd0bd4b9f4d4f5147d5f1bd77d971ccd8f8b8fb0df8acf9c1fac9855090e9cb4af8849343be SHA512 d147614fd85a2cad69d6e6f83711a6dc556a4a62217c91ffcdf054895ac5d8867cb426d4ecab7223e13cf5db8c157e5049b98c307eabece1090f63b072e482bb
EBUILD pytest-httpserver-1.0.9.ebuild 784 BLAKE2B 48f7159e96013b3606b2967793ff66a88cedf24fb5e537696e11e9eb571430bbabc81b7863d9e5bbc62a281e224afec5bb8438e2e1cc59fd008d2a1e3792e4f1 SHA512 642c0c10eda4d2a9cb480dc8a27261031cded33bd2df49595ae8e30232871232ae5ff5d17a5659a40c2154b65952c59dde0c1d7f9a68fa57d050d037bf76526a
MISC metadata.xml 411 BLAKE2B 330f12d8e60a13fe3f4872f3aac04a3d62ba0314adad555e02bb5467ac7a581d3352f308ac66c9aea8b704b5f25860594017bf10ee96f5df216f6e3c10329e07 SHA512 ea6f51163452653eaa1bc9c631f5838bd9461b7c11ef2a06dd52c3d45ca9a220836b4e5e01e52bb0dbadd9bcb10a46fbec905777d0f5d9034b2f6f3cb1d6c0e8
diff --git a/dev-python/pytest-httpserver/pytest-httpserver-1.0.10.ebuild b/dev-python/pytest-httpserver/pytest-httpserver-1.0.10.ebuild
new file mode 100644
index 000000000000..79f60d637991
--- /dev/null
+++ b/dev-python/pytest-httpserver/pytest-httpserver-1.0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP server for pytest to test HTTP clients"
+HOMEPAGE="
+ https://github.com/csernazs/pytest-httpserver/
+ https://pypi.org/project/pytest_httpserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests from building release artifacts
+ tests/test_release.py
+ )
+
+ epytest -p no:localserver
+}
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 8f8cf08b59db..473c91b733da 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -2,7 +2,9 @@ AUX pytest-7.4.3-no-color.patch 1293 BLAKE2B 85ae23dc612eb7825f4c3ba2d727a611554
DIST pytest-7.4.4.tar.gz 1357116 BLAKE2B 0bf281b3d4b7b2eb7805423a75c8c2befa820cc230318511e5a2d5ea35321a78a2603d5dbc033414ed73171525371efa9d9f54083d5638fc752c1c218e6d53aa SHA512 28a259dac6739683c131993409d508e10fbfee461291b8fc7697dd83f30725a3c60e681ba00b5669a215af6a5e683f07a329485d780acc9ad0372a6552f783a1
DIST pytest-8.0.0.tar.gz 1395242 BLAKE2B 99d0dce33a2a9c0c421777779584b6f74950e27c4a3a64daaf9fbb9d6a28583cff1890ebd6f471e1ffdc6f9d3cfc69deb513b6884ec216a7e95b16eba8c59c5e SHA512 18c09d378e02a5b33bdf269aa27b6a4e84d43c46a702d34252ddf01a7cab3d56c8c9793ed4605ae041fc8c8845016b69dba4eb1f723756bab3704ab3e079b551
DIST pytest-8.0.1.tar.gz 1396338 BLAKE2B feb21b576e1c82376481493d4c7c345f16ac7c818c13b88d37a2b5c3ecdbb6fa7397243f8672df320657a4a6fd654267760a278313fd0cba069da950834fdb55 SHA512 ce1fa9fa2a78f73320e1692681930c7bee5f6bd66b592d6f8b7e6c958cbdc180d9b1f39ecad2556c0811c5337e7fa28b84a093f064ac46f7fd3c4a6d94b3e73a
+DIST pytest-8.0.2.tar.gz 1396924 BLAKE2B ad95d246f5592cfe54faea6c96e38cb60d3e2713070d1ff7cab6c42aea312883c5d97c99a930dbcbd8493e966c4b8351320f6494b4ab904afbf21d7e1dd004a7 SHA512 c495943baad05e09b467d23c7afadb3edff7ae93ee96290d6db9e64739236888148b63dff7e8e25b331b11bd48c55fb0ca8901cf823d69b1a922e94915bab2f1
EBUILD pytest-7.4.4.ebuild 3796 BLAKE2B 1bee0d6df20d013802a7de4abc2937af9e3bfe99215d07a9ba888538f8526b6a14f1e4c41554f9a847d47867bb3dea34d8678e9a61a1e6b8fded8f336e21d4da SHA512 74823f180543e26b51739781b369db414ecbd0784d9cd8883ddc053831922001ec120247d7adac275830e5fe836972f7b6dd7c05c018f0ff122c4248b6c1fa3e
EBUILD pytest-8.0.0.ebuild 3699 BLAKE2B d03c3eed4dee19a94dbd7fe6a4074ca30f1ffe1fab9741475df334f39b516f15bd15f47a514ed7418f5608181b8b58d4fefe7eeefa75e5bac2f8c4d8db9e70a4 SHA512 dcd37a1f0935839f45d07f5ed7e5db680888c75839035a4f84f65b22c54e14463906df9459a199c54bdabbeabfb38629fc0248cec7aca52bbdd08ee31bf67216
EBUILD pytest-8.0.1.ebuild 3699 BLAKE2B d03c3eed4dee19a94dbd7fe6a4074ca30f1ffe1fab9741475df334f39b516f15bd15f47a514ed7418f5608181b8b58d4fefe7eeefa75e5bac2f8c4d8db9e70a4 SHA512 dcd37a1f0935839f45d07f5ed7e5db680888c75839035a4f84f65b22c54e14463906df9459a199c54bdabbeabfb38629fc0248cec7aca52bbdd08ee31bf67216
+EBUILD pytest-8.0.2.ebuild 3776 BLAKE2B 23f18a4e37ad7af7320179546b7a518bdaaad43a24dd021ac660ca396b0eec98a89288903a49e2b46898af78bc5646eb7f01098d9018f5ca7862b6cf0d8be0a4 SHA512 91f034bbc96cb2e6d3024a0b39cc2e9007fb77cdac0d0dc2c5c0e6c888027b66f496c79021daf63312c11584f85ffb1f0a0236154bbd0d2ab51f1cdb55131fa6
MISC metadata.xml 391 BLAKE2B 48d31ecb4c8b171ee4e84a58399211368ddc00dfb5dbe0999f96e03d744294cd4fd5263e90600c93d1f13c7da21052faef84b6d0d56709f3559e37b3392ca31d SHA512 6e9caa57eda23995d21df6f52c52d5868e1ff56abb6c1351ffc0fe14b771639473481a2630e659caaff83f0255379aa2d012175af52a0de41221b27d3ab2f425
diff --git a/dev-python/pytest/pytest-8.0.2.ebuild b/dev-python/pytest/pytest-8.0.2.ebuild
new file mode 100644
index 000000000000..c96c58105a4e
--- /dev/null
+++ b/dev-python/pytest/pytest-8.0.2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="
+ https://pytest.org/
+ https://github.com/pytest-dev/pytest/
+ https://pypi.org/project/pytest/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/iniconfig[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-1.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.2.3[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.7.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+src_test() {
+ # workaround new readline defaults
+ echo "set enable-bracketed-paste off" > "${T}"/inputrc || die
+ local -x INPUTRC="${T}"/inputrc
+ distutils-r1_src_test
+}
+
+python_test() {
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Skipping tests on ${EPYTHON}"
+ return
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x COLUMNS=80
+
+ local EPYTEST_DESELECT=(
+ # broken by epytest args
+ testing/test_warnings.py::test_works_with_filterwarnings
+
+ # tend to be broken by random pytest plugins
+ # (these tests patch PYTEST_DISABLE_PLUGIN_AUTOLOAD out)
+ testing/test_helpconfig.py::test_version_less_verbose
+ testing/test_helpconfig.py::test_version_verbose
+ testing/test_junitxml.py::test_random_report_log_xdist
+ testing/test_junitxml.py::test_runs_twice_xdist
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_normal
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_normal_count
+ testing/test_terminal.py::TestProgressOutputStyle::test_xdist_verbose
+ testing/test_terminal.py::TestProgressWithTeardown::test_xdist_normal
+ testing/test_terminal.py::TestTerminalFunctional::test_header_trailer_info
+ testing/test_terminal.py::TestTerminalFunctional::test_no_header_trailer_info
+
+ # unstable with xdist
+ testing/test_terminal.py::TestTerminalFunctional::test_verbose_reporting_xdist
+
+ # TODO (XPASS)
+ testing/test_debugging.py::TestDebuggingBreakpoints::test_pdb_not_altered
+ testing/test_debugging.py::TestPDB::test_pdb_interaction_capturing_simple
+ testing/test_debugging.py::TestPDB::test_pdb_interaction_capturing_twice
+ testing/test_debugging.py::TestPDB::test_pdb_with_injected_do_debug
+ testing/test_debugging.py::test_pdb_suspends_fixture_capturing
+
+ # setuptools warnings
+ testing/acceptance_test.py::TestInvocationVariants::test_cmdline_python_namespace_package
+
+ # times out
+ testing/test_debugging.py::TestPDB::test_pdb_interaction_exception
+ testing/test_debugging.py::TestPDB::test_pdb_with_caplog_on_pdb_invocation
+ )
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ # regressions on pypy3.9
+ # https://github.com/pytest-dev/pytest/issues/9787
+ testing/test_skipping.py::test_errors_in_xfail_skip_expressions
+ testing/test_unraisableexception.py
+ )
+
+ epytest -p xdist -n "$(makeopts_jobs)"
+}
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index b5071f8da5cb..029e0c688472 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,3 +1,5 @@
DIST rq-1.15.1.gh.tar.gz 633531 BLAKE2B e1cf463e54533a1a56fab98a66f4cfe2ef73da48ab965a10066b84050aa1ac72373328246236fbd45bdf3d026ffc355aa117a21047dce1cef16b18c6e96a0f3f SHA512 75228f037c5c731f7788bb18654f2e07a9af39f8980900166e07145887f7cbed06fbd7fb5513a770cee791d07a49d85a544b83f347cce6726d7745f8396e3aac
+DIST rq-1.16.0.tar.gz 627998 BLAKE2B cff296147f92d234a29f3e1c0f762bcaf873aabebc3cea816e8a772586e41ca850bba600d1e6e974ebfe1da4286ee4b15a5326cb0fee1a082b7bc632005b3ef5 SHA512 8746bed4d9fccd2f74ceb3ba026268f3c7441f278348e2823e6dbaf95326ff396f76564f3622c94440fef4b0a49b5fadc5680b1abdb3cfaacfa1118aa85c8457
EBUILD rq-1.15.1.ebuild 1444 BLAKE2B cc0a48b0d249bd0f04cbe89b0751df613e110bd467b639bbd8c3df1e25c8642635a8cab902d8f0c5d98a8ed4e039d241dc2e712ef0e8428ae5a26bf3e7440c4b SHA512 fb337dad159eb75080893a48b2a2bc7f6634479f15361f832734fae69255151253433f29abfa9303ec3ffa45ea4845dbc00e556f7af0791a943c5c9977cdbad9
+EBUILD rq-1.16.0.ebuild 1332 BLAKE2B d0514b70af8f560334d6d563644926e0b9fa5cc2c1d92930466495d29e9698918c68964c1e3baf98e5aca6c16eccb4d891adb927fa159ffdcf5718a745a6a998 SHA512 b1452dced3349b8e2330839e8ad7adce2882a5c91ad20c326705998fe9ce02af93d267affd4320a60934a7b3edef6295e56f8b05d7c9e80d7fdda887e931b73b
MISC metadata.xml 453 BLAKE2B 6a46d43b524fded1ad4749fb9669ea07f8b3e23940d0bf2a4db5d92564316b01fdfbe220771e30b1a110ef72c613ad683cdcb7940682ea32198a5b6f027e4db3 SHA512 104ef96c34b55a9fda377c1304ff85781219fdbccef1a83d1bef30cb2fbd0ef816cfe82715af8937f452499135f7ed65c65a29c34919a09b6144ada367c26af5
diff --git a/dev-python/rq/rq-1.16.0.ebuild b/dev-python/rq/rq-1.16.0.ebuild
new file mode 100644
index 000000000000..ac48b2056812
--- /dev/null
+++ b/dev-python/rq/rq-1.16.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="
+ https://python-rq.org/
+ https://github.com/rq/rq/
+ https://pypi.org/project/rq/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}