summaryrefslogtreecommitdiff
path: root/dev-python/typogrify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/typogrify
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/typogrify')
-rw-r--r--dev-python/typogrify/Manifest2
-rw-r--r--dev-python/typogrify/typogrify-2.0.7-r1.ebuild (renamed from dev-python/typogrify/typogrify-2.0.7.ebuild)15
2 files changed, 12 insertions, 5 deletions
diff --git a/dev-python/typogrify/Manifest b/dev-python/typogrify/Manifest
index bfccc80725f2..52b8d3a0d502 100644
--- a/dev-python/typogrify/Manifest
+++ b/dev-python/typogrify/Manifest
@@ -1,3 +1,3 @@
DIST typogrify-2.0.7.tar.gz 12903 BLAKE2B e08b27a531f21e99d5a35c47c1deb94bc7f67e31a47789ba4750520c893633966b1319a731c81ab2435e7024aea1e8fd0b46a52bbb73a050cdf83a1588644d18 SHA512 6212024a88372f1b14e5932c0541ec4d5a2ada7514c1327dc8f3775cd7adf3372cae0037c4310ed4a03fd0657a91eb4c0d114b74172190f7f84d82908441ddd0
-EBUILD typogrify-2.0.7.ebuild 687 BLAKE2B 418dddafb7e0a4a56ef2d814be9e57fb838a0c968dad89b831d4f6f21de7d5a8515878e2265ff6ba7d0d54bd4a5285ed280ba188406bb25294ccdb8f0ae50278 SHA512 d28cf6b3c515255513f73ee5df3891a1f783c81a7ab827549a3fa18583341c5c89658959d5c4f277efa5bda38e322948c78287c94c8da76d5f08eb70c6df988c
+EBUILD typogrify-2.0.7-r1.ebuild 732 BLAKE2B d94debdd48ef7674cb06ac5b3808993e4c762150f9c289a9f5664914daafd8ab706d2c0bff4336f8fee95741dc4058e6bca385776ae085a45fb59d787c6cbda2 SHA512 539088d3450ee08abb445f2e5ab40d0682b0e387df7380a8c79c0a7c6683b4dd4a90039fa517f9fcce92a1f3a9fe3290f3f66c66b050045add72f6805cd11a6c
MISC metadata.xml 464 BLAKE2B 444a374a2f105a3ca17c78e8ab53300ecf6ea64669031e493a5a211d035a40104a1b97306817f0d9d02bed770100a8cd39b73ebbc273dbfd9f8dae8922ebf92a SHA512 1016d229071882740becd626c26283fb113205c2e327d668aee7ad47a512618a9e5820fe795298bb44ac54d602fdc8b55a7062e84936d79a01e7dc3271f574f6
diff --git a/dev-python/typogrify/typogrify-2.0.7.ebuild b/dev-python/typogrify/typogrify-2.0.7-r1.ebuild
index 4528bdc47264..523c52bbe2fc 100644
--- a/dev-python/typogrify/typogrify-2.0.7.ebuild
+++ b/dev-python/typogrify/typogrify-2.0.7-r1.ebuild
@@ -1,13 +1,18 @@
# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
-PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Filters for web typography, supporting Django & Jinja templates"
-HOMEPAGE="https://github.com/mintchaos/typogrify/ https://pypi.org/project/typogrify/"
+HOMEPAGE="
+ https://github.com/mintchaos/typogrify/
+ https://pypi.org/project/typogrify/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
@@ -21,5 +26,7 @@ RDEPEND="
distutils_enable_tests pytest
python_test() {
- epytest --doctest-modules typogrify/filters.py typogrify/packages/titlecase/tests.py
+ epytest --doctest-modules \
+ typogrify/filters.py \
+ typogrify/packages/titlecase/tests.py
}