summaryrefslogtreecommitdiff
path: root/dev-python/sure/sure-1.2.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/sure/sure-1.2.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/sure/sure-1.2.5-r1.ebuild')
-rw-r--r--dev-python/sure/sure-1.2.5-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sure/sure-1.2.5-r1.ebuild b/dev-python/sure/sure-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..68514254ce81
--- /dev/null
+++ b/dev-python/sure/sure-1.2.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Utility belt for automated testing in python for python"
+HOMEPAGE="https://github.com/gabrielfalcao/sure"
+SRC_URI="https://github.com/gabrielfalcao/${PN}/archive/${PV}.tar.gz -> ${P}-r1.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ ~dev-python/rednose-0.4.1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${CDEPEND} )
+"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${P}-r1"
+
+python_prepare_all() {
+ sed \
+ -e "82s/read_version()/'${PV}'/" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -s tests --rednose || die "Tests failed under ${EPYTHON}"
+}