summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-testing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/sphinx-testing
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/sphinx-testing')
-rw-r--r--dev-python/sphinx-testing/Manifest1
-rw-r--r--dev-python/sphinx-testing/sphinx-testing-1.0.1-r2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/sphinx-testing/Manifest b/dev-python/sphinx-testing/Manifest
index 25ee43885272..3c6d5234d58e 100644
--- a/dev-python/sphinx-testing/Manifest
+++ b/dev-python/sphinx-testing/Manifest
@@ -1,3 +1,4 @@
DIST sphinx-testing-1.0.1.tar.gz 11513 BLAKE2B 46ede243507a0d90b2ad4b918deadb818491bb0ed15ce41886040c52650f9fd348ff57c03766fd1e7719bbb54726f8915e091cf94a5396da946102ca49fd07b2 SHA512 2d377c0c6fe8e34a463b35e96938507a3ca35fa06cd19a2682eb55825e1b88982a80a02ebb9a02a47f11ca5e8fe6a5b9e5c8114d955fa3b774e0148e82121818
EBUILD sphinx-testing-1.0.1-r1.ebuild 573 BLAKE2B 60f7f65cddc1a4d4c0ac346e1f7d4f39efaf7359284ca275a9a1fad793832f5f0d85f20a03112d69fcb924502b74e09ebbd9691eea758ea55952e3cb55189a40 SHA512 dc857b6145fbc3fc8c4be486d34bcf9c9c2a37135011f76c32964ed4c8acc07f54e8b9a046abca140de1b57adee0bf003ca3f76c9078e3b57a0ae37ebbc4072f
+EBUILD sphinx-testing-1.0.1-r2.ebuild 616 BLAKE2B a0cd3277bf2e7a99d0dcc7c6bad45aed8e56992f741dddcbe774e42de2a8216e42da9cd51d98af280d0c9bd1bec1bd0f1734d9ec1e7b493157294759b03e256a SHA512 d4a32e043e94393ffbe47c535120949af8e22f77dce747014630b2b27cb443aa2600073aceb4bdc66cb7d308c9e6883c608e6f97e4e6ac7bdf2ba3da518562b4
MISC metadata.xml 383 BLAKE2B 41e841d52facd1baa27b1792d1200e275c4925c84d45ab17fe3ed243107de05e0cd70b9e73227bf7cdeabee8ef03175da471a7d357228e546df35fd1c7de9d24 SHA512 2fe1d7bc1e88c836b2ed8ce0f2cd6e71b5ea52fd94c0581c29a285402ba8f81f62cdece2b86776a02a9082ce7ee52f0881088fa28c263c7a2a8a85b1614b7ae6
diff --git a/dev-python/sphinx-testing/sphinx-testing-1.0.1-r2.ebuild b/dev-python/sphinx-testing/sphinx-testing-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..ad296d151157
--- /dev/null
+++ b/dev-python/sphinx-testing/sphinx-testing-1.0.1-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
+HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest