summaryrefslogtreecommitdiff
path: root/dev-python/rpyc/rpyc-4.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/rpyc/rpyc-4.0.2.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/rpyc/rpyc-4.0.2.ebuild')
-rw-r--r--dev-python/rpyc/rpyc-4.0.2.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/rpyc/rpyc-4.0.2.ebuild b/dev-python/rpyc/rpyc-4.0.2.ebuild
new file mode 100644
index 000000000000..f3e1ff38ded2
--- /dev/null
+++ b/dev-python/rpyc/rpyc-4.0.2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Remote Python Call (RPyC), a transparent and symmetric RPC library"
+HOMEPAGE="https://rpyc.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="dev-python/plumbum[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"