summaryrefslogtreecommitdiff
path: root/dev-python/recurring-ical-events
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-02 15:07:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-02 15:07:39 +0000
commit52895d302231ef73b105756d2781b2262638d566 (patch)
tree7a2e0cf7cae8995cbbb6f9ae807d5c49b4f2b77c /dev-python/recurring-ical-events
parent68f980204de6c2d69eed8748edc90282879326a6 (diff)
gentoo auto-resync : 02:02:2023 - 15:07:39
Diffstat (limited to 'dev-python/recurring-ical-events')
-rw-r--r--dev-python/recurring-ical-events/Manifest5
-rw-r--r--dev-python/recurring-ical-events/metadata.xml13
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-2.0.0.ebuild45
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-2.0.1.ebuild45
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-python/recurring-ical-events/Manifest b/dev-python/recurring-ical-events/Manifest
new file mode 100644
index 000000000000..da8f4ab8c86b
--- /dev/null
+++ b/dev-python/recurring-ical-events/Manifest
@@ -0,0 +1,5 @@
+DIST python-recurring-ical-events-2.0.0.gh.tar.gz 325608 BLAKE2B 386ab8a54343fb02c15938801c15b31c8c8ba6bd0888a677268625fcba5571724d53c42f9d093ea8590d6e3557c151b73f9fb532a1bea194bc6d7032e04946e9 SHA512 676bc074a4d9ddb2bf0aefe8e118eab6e80479bb0d585b9f4c50f4bd49c7adf03e484b34bdf01596bb012c903a8017644ff74026d333f13f5c7df2c4326ab18c
+DIST python-recurring-ical-events-2.0.1.gh.tar.gz 326015 BLAKE2B c85d0626f86b90c5c597d9f437f66d0e6cf5c4afbf8f6c521ccf52562a16953fe13c0804f23386276adc252620fcfb6fda69ccbe90ad8b1a4b105f5d5cd34939 SHA512 f12807767a903a90e2348a416bb78873f40238653cc83d50cf51080cf5f214df8b83dca71095b440e73fac9193c10bcd42ea4129edfe3a42607a85b45dfef03b
+EBUILD recurring-ical-events-2.0.0.ebuild 1131 BLAKE2B 66b264c0766174efc6e9006fa3270c4a54c2a851d835d5ee1eda659f710601e6ce8c0ae490a07a9fc84d1d21bfb550de60673b1df549548dcd5a551ea3cab68d SHA512 b4f382546e0f229cbadab9135155428e076ae605c78438ed0dda87455478e68fc6eb07d3c19ca6bada4396372cda86f08a632861da0a7d964b9573855edff355
+EBUILD recurring-ical-events-2.0.1.ebuild 1131 BLAKE2B 66b264c0766174efc6e9006fa3270c4a54c2a851d835d5ee1eda659f710601e6ce8c0ae490a07a9fc84d1d21bfb550de60673b1df549548dcd5a551ea3cab68d SHA512 b4f382546e0f229cbadab9135155428e076ae605c78438ed0dda87455478e68fc6eb07d3c19ca6bada4396372cda86f08a632861da0a7d964b9573855edff355
+MISC metadata.xml 431 BLAKE2B 19ac0f0a385fb9b0524bf641831fbe3c02f35f3ada35922b297563f871cb8e745404e04d18d9f7428ef5b3cca27f5205f4a7f99e85e2a3da18542a19574f04de SHA512 35283cfbd447b3ec9d0d97ec7c11580db012ee60076b12ba733962d58896203a162ece04a9015eca8cc556f28fac307fc9ddeb27c3ea9cb9c8b2d6df0cf93a50
diff --git a/dev-python/recurring-ical-events/metadata.xml b/dev-python/recurring-ical-events/metadata.xml
new file mode 100644
index 000000000000..3c5c8d8ba58d
--- /dev/null
+++ b/dev-python/recurring-ical-events/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">niccokunzmann/python-recurring-ical-events</remote-id>
+ <remote-id type="pypi">recurring-ical-events</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-2.0.0.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-2.0.0.ebuild
new file mode 100644
index 000000000000..77305260c9e3
--- /dev/null
+++ b/dev-python/recurring-ical-events/recurring-ical-events-2.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)
+
+EPYTEST_DESELECT=(
+ # a test checking if tzdata package is installed that is apparently
+ # needed for other tests, except it isn't
+ test/test_zoneinfo_issue_57.py::test_zoneinfo_must_be_installed_if_it_is_possible
+)
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-2.0.1.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-2.0.1.ebuild
new file mode 100644
index 000000000000..77305260c9e3
--- /dev/null
+++ b/dev-python/recurring-ical-events/recurring-ical-events-2.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)
+
+EPYTEST_DESELECT=(
+ # a test checking if tzdata package is installed that is apparently
+ # needed for other tests, except it isn't
+ test/test_zoneinfo_issue_57.py::test_zoneinfo_must_be_installed_if_it_is_possible
+)