summaryrefslogtreecommitdiff
path: root/dev-python/quixote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/quixote
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/quixote')
-rw-r--r--dev-python/quixote/Manifest3
-rw-r--r--dev-python/quixote/metadata.xml12
-rw-r--r--dev-python/quixote/quixote-2.8.ebuild45
3 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/quixote/Manifest b/dev-python/quixote/Manifest
deleted file mode 100644
index 2fe9b1ff2493..000000000000
--- a/dev-python/quixote/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST Quixote-2.8.tar.gz 474323 BLAKE2B 862ae01d546203cd4b8791d615e3c354990bf4d6f0d615873c4e987de64fe3d9dbeaf7b37d642cb3024da3ecd8887962e3d878f2a3fe4f07c1dd0be80b52b4a0 SHA512 d25e82228706966d1e3e24a07b8d1b62a016571f80ad375fa846be9fd720d6c2c8009b53f7abf72cd14ade36b3a69ac9a153d7017a88b5d420d571da45bc6558
-EBUILD quixote-2.8.ebuild 1044 BLAKE2B 33b8cc3d0d4b0444e94cdb638933576b6c0b0d1653f452d1334c906ce31b74e105f8c9c5a982fab225ff92a260b6d3b4a571fae7210e982ee77894329680e1a3 SHA512 dd27152e84c5c8c76ca716399ccdb9486c0e145a2bcebc50078244c838cacb77fbc522ca3a1afc2d1bbcda6d8e233f1b48ab1cf22565222d471e04a7f838cb60
-MISC metadata.xml 350 BLAKE2B 8d3b4403e785a7dc7165a349dcb7b48ceca5892ca1e96ce825d88d346dde0001519d2110b483ebf0c1b1fe18bffad9d01607a6bb1e5364f06fbb7d667b44d257 SHA512 f0e59fdd63ae61df0a1c12b78d766216aa09d552f5c90d4088cddd85477ad9cba6be93a866a78fa22d46de2c90a01cf4e43b77eb483f0e0b2e5303bb2d62dff5
diff --git a/dev-python/quixote/metadata.xml b/dev-python/quixote/metadata.xml
deleted file mode 100644
index 0fc88ced4a7a..000000000000
--- a/dev-python/quixote/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
-<maintainer type="project">
- <email>web-apps@gentoo.org</email>
- <name>Gentoo Webapps</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/quixote/quixote-2.8.ebuild b/dev-python/quixote/quixote-2.8.ebuild
deleted file mode 100644
index b6c839af7617..000000000000
--- a/dev-python/quixote/quixote-2.8.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-# Appears to be written only for py2
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 flag-o-matic
-
-MY_P="${P/q/Q}"
-
-DESCRIPTION="Python HTML templating framework for developing web applications"
-HOMEPAGE="http://quixote.ca"
-SRC_URI="http://quixote.ca/releases/${MY_P}.tar.gz"
-
-LICENSE="CNRI-QUIXOTE-2.4"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc test"
-
-DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}"/${MY_P}
-# tests require a running quixote server, prob. apt. post install. Tried the demo one but no
-RESTRICT="test"
-
-python_compile() {
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
-
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C doc
-}
-
-python_test() {
- nosetests tests || die "tests failed"
-}
-
-python_install_all() {
- local HTML_DOCS=( doc/. )
- distutils-r1_python_install_all
-}