summaryrefslogtreecommitdiff
path: root/dev-python/python-scw
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-scw
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-scw')
-rw-r--r--dev-python/python-scw/Manifest3
-rw-r--r--dev-python/python-scw/metadata.xml8
-rw-r--r--dev-python/python-scw/python-scw-0.4.7-r1.ebuild22
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-scw/Manifest b/dev-python/python-scw/Manifest
new file mode 100644
index 000000000000..f5f6bae3f11e
--- /dev/null
+++ b/dev-python/python-scw/Manifest
@@ -0,0 +1,3 @@
+DIST python-scw-0.4.7.tar.gz 337703 BLAKE2B eedd3c3650946b30fbc044d9cc295e2ec5a7a700e1e1b24b669200318bc40ec0099a2dd0078b12d46ef7d3e9d0594cdb7f77811ef2a4cc8fb7889c8e228a0c37 SHA512 c731527ed1c3372440a428335f2f318307c970b6ee4a09af9c4eeaf89e681a335130ed855a3bb239bf5f44bfee1f0772d3f19afd07c7bbc180c586646fdd9a07
+EBUILD python-scw-0.4.7-r1.ebuild 522 BLAKE2B f1a5f08a3684e42bf7d361c5ee2fa46f7a36f6cefd9f99b106cf69b6ee45077ab9199ccbcd11e2910fc6f6f1e9c94c445d01a1908554967db4353d377568fd11 SHA512 b2af6a3c316b459480d74b9669c308d0fc93a50aeff4498e1caf98d2cb072e998052bfb282fb518a72d465daad218800d9d722e0e2bea5460db23c8dd5780059
+MISC metadata.xml 240 BLAKE2B 41e6a4d9da33dab2decc5ff419924f382a8f64d27a81fdb97576db8c6cf125be95911747946ec8be1b453f56617fef1084f5947f84b50a8db419d46df2ae8a0f SHA512 9c23321eaa853f851bf00195ea64ac2ba093e516f9b57855ee5aa58fbb1988130c9f0c17c2a9ce9fae4ee033e0a28a70c868e0f5acdfa1dd316ab533c5279d59
diff --git a/dev-python/python-scw/metadata.xml b/dev-python/python-scw/metadata.xml
new file mode 100644
index 000000000000..7f4f33c6dbc9
--- /dev/null
+++ b/dev-python/python-scw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-scw/python-scw-0.4.7-r1.ebuild b/dev-python/python-scw/python-scw-0.4.7-r1.ebuild
new file mode 100644
index 000000000000..ed30a025fd78
--- /dev/null
+++ b/dev-python/python-scw/python-scw-0.4.7-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Python binding for Scw"
+HOMEPAGE="https://sites.google.com/site/scwwidgets/"
+SRC_URI="https://sites.google.com/site/scwwidgets/${P}.tar.gz "
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygtk-2.4[${PYTHON_USEDEP}]
+ >=x11-libs/scw-0.4.0"
+RDEPEND="${DEPEND}"