summaryrefslogtreecommitdiff
path: root/dev-python/python-bibtex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-bibtex
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-bibtex')
-rw-r--r--dev-python/python-bibtex/Manifest3
-rw-r--r--dev-python/python-bibtex/metadata.xml15
-rw-r--r--dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild34
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/python-bibtex/Manifest b/dev-python/python-bibtex/Manifest
new file mode 100644
index 000000000000..5b3921d9d008
--- /dev/null
+++ b/dev-python/python-bibtex/Manifest
@@ -0,0 +1,3 @@
+DIST python-bibtex-1.2.7.tar.gz 60894 BLAKE2B dae5162e9d4b6893a4d411ffd1926f7f989940440609737b5c307af574d6e2794b850d6e4cb60bf33ba96eb36b3a0143fbc8fee907fc96c0c7d980514fe8db5d SHA512 6739824fcdad91e2abb333d9e17a31bd222e6100630b8e4f65a9e718d36eb451600fdc7380cb63b89c4a33a7554b79dd1c52448d19c3359f21deee2134242e6b
+EBUILD python-bibtex-1.2.7-r1.ebuild 662 BLAKE2B d9274d810a7005b47f159f623d2eef3ea16915437db8433cf4152a29a57f8a5bfb1ccea92c12b367ec4879c091f96eea5d1abfa2f22b11664bd75585b195d2ad SHA512 8d9f512e261cf292b8b75db0b7c5cefa9ffb6b54162bca9a5b2360d0c788564d6618de1c88c7f77468c9d9fff6feeb5048306697e09864e98f55af65a9b777d5
+MISC metadata.xml 433 BLAKE2B 7d50fbbf95bffeecb213069d61af760c468d50ffcfe3c7dbbcf504cf496b944dc83671122400662fc4247bba54fef57eb085f86039c6e7600139b1e0b51398c8 SHA512 2f628ff97966f5175f2a5deab9a04f09c7350b2a74a99ad37930cbeee9881d8911d821af89c92eb832560e58cfcb7efd8af0c8f51ab3bac4ab1fbdd94e1639cc
diff --git a/dev-python/python-bibtex/metadata.xml b/dev-python/python-bibtex/metadata.xml
new file mode 100644
index 000000000000..56e91f1d6c4c
--- /dev/null
+++ b/dev-python/python-bibtex/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pybliographer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild b/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..6b44d83e3241
--- /dev/null
+++ b/dev-python/python-bibtex/python-bibtex-1.2.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A Python extension to parse BibTeX files"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ >=app-text/recode-3.6-r1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+python_prepare_all() {
+ # Disable tests during installation.
+ sed -e "/self.run_command ('check')/d" -i setup.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py check
+}