summaryrefslogtreecommitdiff
path: root/dev-python/pycryptodome
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/pycryptodome
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/pycryptodome')
-rw-r--r--dev-python/pycryptodome/Manifest2
-rw-r--r--dev-python/pycryptodome/pycryptodome-3.10.4.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pycryptodome/Manifest b/dev-python/pycryptodome/Manifest
index 6eea3090948d..55e068163e1f 100644
--- a/dev-python/pycryptodome/Manifest
+++ b/dev-python/pycryptodome/Manifest
@@ -1,5 +1,7 @@
AUX pycryptodome-3.10.1-parallel-make.patch 837 BLAKE2B 9d7b3088d547d294dab498dbdcdef7f5eeec0ef8c264fd62a49e2e64a9adfc785f8becae91a6f889184e53af04aabe638d503f523daa62edaa3bf91596a268bd SHA512 2b2f310a3ab332f9d1c2f7742fdd902cfbecf49360df3412839cb67bf69e8eb1f9e051461d4264ff7d732d1bbad285b5a635aea085945d543c2b58e880f0b807
AUX pycryptodome-3.10.1-system-libtomcrypt.patch 1729 BLAKE2B 57a2022ef17e0b86e98b085336f5ce815304e326a5a2bd5cc8ff5d33b6efba440505767517b79c2f0bba39ab33f04d7434a3f0ee529b880ff7552aee2805dab5 SHA512 d53677c0ad96f161f9aed14b8f353a8cc12c92f31de9733789f9c4151710376d33e974fd611b763de94c631796d7a57cd8787656e3c1e985696e20537b34760e
DIST pycryptodome-3.10.1.tar.gz 15545471 BLAKE2B ef1922efd0b6bef6beaee76fe03a4201a6f1cf2a203abcb12b96a5ea7c8de59a34ac704fe7508a3728a214efc0755f289d66dc14a0adb3f2eac882bc8db691bf SHA512 4c7e7e989d5363064e7e184f6b00a174045e03916cdf1199626afd7fe75eb5efcd13888ecdee607b974e96faad465694b384eb6d91edb8de1d0277ad71888c52
+DIST pycryptodome-3.10.4.tar.gz 15552675 BLAKE2B aaa6e6768d099b7b229f2b920671577800baea11b8b5a8efdd818f3d5685e46ac51d1c79d9c987f1d93cc9df98c786028137348c946da7aff35fc436ff21894c SHA512 1ee2f6c499d7ea73bdeafc94b1e91b45bf888f84ea214a01db180e030b4724264ba05e16241c465484ec13075f5300f6c489229bedb84e54b93e2852906b634f
EBUILD pycryptodome-3.10.1.ebuild 1533 BLAKE2B 93b9523336f06fa12c19140fc4dbfe1e1aa2c0be7e7d48955b3e86b0ca461a0b8b4d360e9e6e37448cb9434426db78ff3a7d7ee646a8d04fe2349c945f60e903 SHA512 671ceadeb8fd10c0fb8a4bdba29f082f192f03f4163b92fbe753fd46c7fe1b9a3c9371f6460dac44552e5485fbb337726098bf1c0e24d4777763777ac60bc9c3
+EBUILD pycryptodome-3.10.4.ebuild 1130 BLAKE2B 0c62e744f70243af0b9ba0327ae23dfe81861241b054dcf1eb34d811f8c10ae0a6592d739969a41d0ab8ce391182e164cf0e415aff14159d9ef56140f7b444a6 SHA512 ab65e2c962ce6bf7a64431e353fe2899f0182cbd51e7dfe4eff70dd3e9607c612b27b254053389aec2eaba2c5d5f298bf6e815c16e3d29cc976896a123b938a3
MISC metadata.xml 386 BLAKE2B 1ec04c0cb752414f063177e637f1fc3e3c401db0c1f245cb33a3690e25597098b25fb2cd5f3ab99838a8bf8339906e2b23e325af5c7248fd880563c872c6fb60 SHA512 f19e2537c5a985389182860eaa45ae68a37ef1167c4b76b452513987fae6fcfb3534d102a079a003770372bbdb4f1997460c982b355f76d09f2387996e18091b
diff --git a/dev-python/pycryptodome/pycryptodome-3.10.4.ebuild b/dev-python/pycryptodome/pycryptodome-3.10.4.ebuild
new file mode 100644
index 000000000000..b9f61b34e0f8
--- /dev/null
+++ b/dev-python/pycryptodome/pycryptodome-3.10.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="https://www.pycryptodome.org/
+ https://github.com/Legrandin/pycryptodome/
+ https://pypi.org/project/pycryptodome/"
+SRC_URI="
+ https://github.com/Legrandin/pycryptodome/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ dev-libs/gmp:0=
+ >=dev-libs/libtomcrypt-1.18.2-r1:="
+BDEPEND="
+ virtual/python-cffi[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+ !dev-python/pycrypto"
+
+PATCHES=(
+ "${FILESDIR}/pycryptodome-3.10.1-system-libtomcrypt.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # make sure we're unbundling it correctly
+ rm -r src/libtom || die
+
+ distutils-r1_python_prepare_all
+}