summaryrefslogtreecommitdiff
path: root/dev-python/pybtex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-python/pybtex
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-python/pybtex')
-rw-r--r--dev-python/pybtex/Manifest4
-rw-r--r--dev-python/pybtex/files/pybtex-0.22.2-fix-test-installation.patch11
-rw-r--r--dev-python/pybtex/metadata.xml16
-rw-r--r--dev-python/pybtex/pybtex-0.22.2.ebuild30
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pybtex/Manifest b/dev-python/pybtex/Manifest
new file mode 100644
index 000000000000..5dd3f637318e
--- /dev/null
+++ b/dev-python/pybtex/Manifest
@@ -0,0 +1,4 @@
+AUX pybtex-0.22.2-fix-test-installation.patch 410 BLAKE2B 6c9addde727e5e1c0001a92ad39c307399331e6ff6e1b5aa9cd691e4c8d6381f0d911fc8e622e8a2dd76736fbeb24513751651886a9db0b5e790a509b9043755 SHA512 d357f3f0566fb67b1ce2abb8669429b344f8d6f4bc8651ea913fba3337bfb33a1a7f6a6e1361b42b42cdf92ec09f60c42262f5c41f12da6b34593a1033c732db
+DIST pybtex-0.22.2.tar.gz 363094 BLAKE2B 6e59543a1178f2d3528c8b65b63afd720864fb8f31172e3fa76a36bee3d5dd9f32aa6226fa0a599af0a4705d3c37060417f6e902ec7b900efcc8a6f8487c31e1 SHA512 afabae8c47008651fa9c4c6546bf87f4a2c74d3184f1d0c1b4c2bd68ad8110ea37054026b5934312b86d97354a592bae5c0b6d384003b4e56f0157f6520b77a1
+EBUILD pybtex-0.22.2.ebuild 759 BLAKE2B df045fcdcefe4aa66649535908b9ef0fa351eaa65b4ad2b6d2c1b242ecf27dfc903e58bdbe3d28a2724fb4c3fbbde65b95b9bc203cd94de927eaebb76b9bc954 SHA512 68db3f850d94a9baa3324e00f2ee929bb54af9b165a957c02203a14a50c5a3eedb26ceccff8d0834524793b4324711c62074656bc07b400cb6acc25cf879890d
+MISC metadata.xml 522 BLAKE2B 62e314da62e360861bbe2fe0a8c71dab45a03aeb3161adde5680e19b3d42d51c75294d288b7e7d89483e9dd9392f52b935e1ae33e0f732376284d988061743ec SHA512 9a27f72f6b1c15e6f30f33afd02c830949032c5315bd3b4cde8fe136f82602b32b1e1f7fafb12c58d2decb18e14bc88dfc507014b263dc1911e2e4cf74b677a9
diff --git a/dev-python/pybtex/files/pybtex-0.22.2-fix-test-installation.patch b/dev-python/pybtex/files/pybtex-0.22.2-fix-test-installation.patch
new file mode 100644
index 000000000000..a5420314fd75
--- /dev/null
+++ b/dev-python/pybtex/files/pybtex-0.22.2-fix-test-installation.patch
@@ -0,0 +1,11 @@
+--- a/setup.py 2020-06-02 10:46:54.592360043 +0100
++++ b/setup.py 2020-06-02 10:47:00.482302281 +0100
+@@ -82,7 +82,7 @@
+ ],
+ install_requires=install_requires,
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*',
+- packages=find_packages(exclude=['docs']),
++ packages=find_packages(exclude=['docs', 'tests*']),
+ include_package_data=True,
+ cmdclass={'sdist': Sdist},
+ entry_points={
diff --git a/dev-python/pybtex/metadata.xml b/dev-python/pybtex/metadata.xml
new file mode 100644
index 000000000000..cf290da2e8b7
--- /dev/null
+++ b/dev-python/pybtex/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>william@ewpettersson.se</email>
+ <name>William Pettersson</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pybtex</remote-id>
+ <remote-id type="bitbucket">pybtex-devs/pybtex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pybtex/pybtex-0.22.2.ebuild b/dev-python/pybtex/pybtex-0.22.2.ebuild
new file mode 100644
index 000000000000..5359af384462
--- /dev/null
+++ b/dev-python/pybtex/pybtex-0.22.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="BibTeX-compatible bibliography processor"
+HOMEPAGE="https://pybtex.org https://pypi.org/project/pybtex/"
+SRC_URI="https://files.pythonhosted.org/packages/source/p/${PN}/${P}.tar.gz"
+PATCHES=( "${FILESDIR}/${P}-fix-test-installation.patch" )
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/latexcodec[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+BDEPEND="test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest