summaryrefslogtreecommitdiff
path: root/dev-python/pyatspi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/pyatspi
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/Manifest2
-rw-r--r--dev-python/pyatspi/pyatspi-2.38.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pyatspi/Manifest b/dev-python/pyatspi/Manifest
index 12bb67833ca7..61dda0449e34 100644
--- a/dev-python/pyatspi/Manifest
+++ b/dev-python/pyatspi/Manifest
@@ -1,3 +1,5 @@
DIST pyatspi-2.36.0.tar.xz 315076 BLAKE2B f3f92dafab68ce003e9d63f8ebf901ef834eafb1fab3ddd2051dcfb308b79d7ce6fc4d9187ed51f3af8bebad5e6ef2296c19215ee209ad37fe717f332af8d8f7 SHA512 709236fd992f570426043e32b201bdfee06bb28faa3d1237778f4069d3548b88b8336e53c0951359f5c7e2914b90f6f682ac58e33c84e32f360bdc32662800af
+DIST pyatspi-2.38.1.tar.xz 316724 BLAKE2B 59ca2569575f3d319d33972477ebc966670138df8cb6570ac260dd903f54df66fd12beeeee53e3380938e4571910b99ae2bf3f395776b16a73ac27f8fa023c49 SHA512 bf8f1ee9a6e00014a84e4329bb971bec8b4bc8f72c3905ca585ca20b1cf000b855965159fcc10871eb92e9808a6b41b5d793f3ab563ff0867f185279eedcd487
EBUILD pyatspi-2.36.0.ebuild 1364 BLAKE2B db12843f9d7eba199064a549b35f8af9800e1bab74f59a35873ac5386daded841d7a949f70299bb17d313fbc6795ac07c9eea55d67b585142a3bffd7634017fa SHA512 4ba287e69f8c76087cf4940f55f58c4296e579d0dd4a47e9560d76c3cdd897f8b4f1ee194ba69d53ab864fb2c18227918376fea70b421492f9768f6ed9ee8f54
+EBUILD pyatspi-2.38.1.ebuild 1303 BLAKE2B e3e4fb253fa6e96e0d3dcd863f7ea209e07a5022da884f20c76c9b944a785177551f7a085505b85a3cbb60d843e44794769a37dbc4596bb168d1cc57de9667d4 SHA512 2b7c66b8d66cd23d5bf76d6ef0c88b175ee82fdbeabb6df3945b30ec59fe2c03eb45a531cbd980efdedd8145355c8f0bbe399657b5dc4a16946dd74f45ffd385
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/dev-python/pyatspi/pyatspi-2.38.1.ebuild b/dev-python/pyatspi/pyatspi-2.38.1.ebuild
new file mode 100644
index 000000000000..e1cb0d9edadb
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.38.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit gnome2 python-r1 virtualx
+
+DESCRIPTION="Python client bindings for D-Bus AT-SPI"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/atk-2.11.2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+ test? ( x11-libs/gtk+:3 )
+"
+RDEPEND="${DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-2.34[introspection]
+"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure $(use_enable test tests)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir virtx dbus-run-session emake check
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installing
+
+ docinto examples
+ dodoc examples/*.py
+}