summaryrefslogtreecommitdiff
path: root/dev-python/pillowfight
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pillowfight
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pillowfight')
-rw-r--r--dev-python/pillowfight/Manifest4
-rw-r--r--dev-python/pillowfight/metadata.xml12
-rw-r--r--dev-python/pillowfight/pillowfight-0.2.ebuild22
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pillowfight/Manifest b/dev-python/pillowfight/Manifest
new file mode 100644
index 000000000000..751ceade036c
--- /dev/null
+++ b/dev-python/pillowfight/Manifest
@@ -0,0 +1,4 @@
+DIST pillowfight-0.2.tar.gz 2628 SHA256 15bce1925a3d66940ceb9a33c3c55de8d95462ce136c4d46e8673f2919b401d6 SHA512 2eff2fd0bdf5c02513ddb4838675e7b9f392135ff08a784ca2fedf06c5b96a56af75460559066cc6cded65f3d4da087ac679492b7b1dba23fb557e6ac3565e6e WHIRLPOOL 691e985dd6e8da23d117f1a826a99c1cf80fbe01e4e82be10b1cac1277be292ffb4be233e31c7ea4daf98c1c28af1be7d28a5f43e8535c176b15c7cb180f0e10
+EBUILD pillowfight-0.2.ebuild 546 SHA256 805447145deebc05c176ebbe63c14d0ba7708d58d327094cf39394f89ee25f6e SHA512 b684c366b67591b89a7ed7f061aaa894708624d9cca7a453a4c7c8ed3099a04b096a44ad6b524adb9a46428f2b31083b71ee87f651483d42d1a2ac3378677f2a WHIRLPOOL 220db14c17e77243d049bb05b84e7df1bf4f0e9a5aba0561c373a167b6821d340d1e4e78b827cef1d48f6642fd8b3f799f823fd0752fb7624bcf938c12bf1cf4
+MISC ChangeLog 1431 SHA256 8d6d7854dc0c9ae7ac5704cbed25a773b2779d15f42db764d82674327e3e95b9 SHA512 03ffe74235540bad63034381e7e8cd156d92d84ca847892ba58119f82b06f7ff676c47212025c7c9d56ab23c6721d3497586bbac0bd0b4dd3137edf79e30b7c6 WHIRLPOOL e39e073be3ade6524e4a21422bac4e099af29249a78727ecfecb2f6d87e67b6ebad4349d19311261d5306dfed919b6a1f7c13ff6aa3dc7583a9cc514569d1408
+MISC metadata.xml 388 SHA256 957977e34a9e69610219f99d11ad34dd22cd943ad1d39fc97f7f78dcd5dd49c1 SHA512 63a6f23df5433c9c251cb2ef9d4a2f88a1eeaf390b88b74ed8e80468b81de9537fdcbfa9d8a62109167900ed72cd503de495283d84e1b5fd22892538e2723950 WHIRLPOOL 128f9be6f2f086c18a7777fe7a263a0ccd949a85de4b87d959c9590c3e52c633fd6fb7867546b40c08b09ecf53037fa7202e939a141e87d4b42290836f5da797
diff --git a/dev-python/pillowfight/metadata.xml b/dev-python/pillowfight/metadata.xml
new file mode 100644
index 000000000000..0916aa813f42
--- /dev/null
+++ b/dev-python/pillowfight/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">beanbaginc/pillowfight</remote-id>
+ <remote-id type="pypi">pillowfight</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pillowfight/pillowfight-0.2.ebuild b/dev-python/pillowfight/pillowfight-0.2.ebuild
new file mode 100644
index 000000000000..8ecb6623d6ba
--- /dev/null
+++ b/dev-python/pillowfight/pillowfight-0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Eases the transition from PIL to Pillow"
+HOMEPAGE="https://pypi.python.org/pypi/pillowfight/ https://github.com/beanbaginc/pillowfight"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"