summaryrefslogtreecommitdiff
path: root/dev-python/libpillowfight
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/libpillowfight
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/libpillowfight')
-rw-r--r--dev-python/libpillowfight/Manifest2
-rw-r--r--dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/libpillowfight/Manifest b/dev-python/libpillowfight/Manifest
index 194aff1c8993..b6cd4c158bde 100644
--- a/dev-python/libpillowfight/Manifest
+++ b/dev-python/libpillowfight/Manifest
@@ -1,3 +1,5 @@
+DIST libpillowfight-0.3.0_p20210816.tar.gz 89491019 BLAKE2B 24a658ce461928750582560ef27fbc1ea233bb7c6290053bee7ab3437816fd0e9d7933e36a7a90c75706bdc17024200d16a17ec81c0c30563f043e6d15cc074e SHA512 a731a7d8c8492f5f6229315c8ff48bcdf215acd501d1a5f726f60d6417f77d04b702579d972aaa90f9d01d27b7b167b47f15f435c0fe79598aedb55ac397835b
DIST pypillowfight-0.3.0.tar.gz 41065 BLAKE2B 8e945bb5a96d7ebd610435fd868d12df371c29fbc26a9c57152988a990ad83daf70382bb94e8b5591144e18d6c54702c0a578ea5f29044fcdadd169effcf933c SHA512 2782030eabb665d20cf49de584220fb65417616c3a0e2a0376c91dc2c228b571768ea3a248ebd5ec4d244a1b825e98609a35b736f7f2fdbb3f674b08e891d9a7
EBUILD libpillowfight-0.3.0.ebuild 738 BLAKE2B 6564ed8e9771d93d68c90472b1dedb7610a68ac039f8563deca95bd32b167aa21936c389028e0916fff6fd98f5d354c456f3276b1bcb6cb2d745b4f41fd4c921 SHA512 9758fd2ac793e4bdc471deef97471da6e1ca2e4a36bec334fdbff50035ae2b60d2dfb45a8173f8e619d76415183a999e37f1684ec40fddcd7b1f4541a2cfd0e7
+EBUILD libpillowfight-0.3.0_p20210816.ebuild 969 BLAKE2B 4ee76bdff48df1d5d84f18adef37698d39f37b42e8f52facbf0a7d7e385509a7feb153e6cb8c983879a48383e646e144baf52d739a2d3812639fc8afa9e0f219 SHA512 6408bc47b9c4efe4efcc087ba7f9a10d093383ac5b51a5fd589e8170dee15ae456ae5f9c5a53c110bac5c480c0d1678f7bb1b9ed4d73bca156eddcb4022aacb6
MISC metadata.xml 339 BLAKE2B eb03aef7b22a30ac1461bf4029711508901ad331209fad7a6a78f0ad3a5cf1902ba963d6d8da569349351f854775a452c1efbace189160111738ee5fb58a2110 SHA512 3978257244b718456e3c9b0f3971626bdd6e927e339c58275c44c19d5098290f9e7c824c53d86306ebeadf58d80bc7089d099e5721e70f36d61bcda16a6c626f
diff --git a/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild b/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild
new file mode 100644
index 000000000000..5e1ace91926e
--- /dev/null
+++ b/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+COMMIT="50d965879eb89fdef9be09d6e934329486ff585d"
+
+DESCRIPTION="Small library containing various image processing algorithms"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork/libpillowfight"
+SRC_URI="https://gitlab.gnome.org/World/OpenPaperwork/${PN}/-/archive/${COMMIT}/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" -i setup.py || die
+ cat > src/pillowfight/_version.h <<- EOF || die
+ #define INTERNAL_PILLOWFIGHT_VERSION "$(ver_cut 1-3)"
+ EOF
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp -r -l -n tests "${BUILD_DIR}/lib" || die
+ cd "${BUILD_DIR}/lib" || die
+ distutils-r1_python_test
+ rm -r tests || die
+}